24fps playback issue



I’ve just started ripping my Blurays using MakeMKV but when I play them back on my Slice they playback at 29.97fps rather than 24fps. I have the XMBC Settings/Videos/Playback set to Adjust display refresh rate to On start/stop but it doesn’t seem to make a difference.

When I play the Bluray in the player I get 24fps. The info of the file says it’s 23.976fps, what am I missing?


I’ve always used HandBrake and never had any trouble, but it’s usually a problem with the container… Are you just ripping them off into an h264 raw format or something inside a container (mp4, mkv etc.) I would assume MKV since that’s the default…

In which case it’s usually the timestamps in the container that cause the problems…

I’d suggest just try HandBrake!


Thanks for the suggestions Gordon. I opened the MKV from MakeMKV in Handbrake and converted a chapter using the same as source setting and on a second attempt forcing it to 24fps. Unfortunately both versions playback at 29.97.


I’m still at a loss as to why the MAKEMKV Blurray rips and Handbrake re-encodes are playing back at 29.97 even when MediaInfo/VLC report that the frame rate is 23.976216. I’ve confirmed my Panasonic Plasma TX-P50G30B can support 24fps by playing the original Blurray in my Sony BDP S550.

I’m currently running Kodi 15.3 Git:02e7013 and Slice version: level-20160306102559-r21936-ga5524f0 6.0 if that helps?


How do you know they are playing back at 29.97?

Is this just that the display mode being chosen is the 1080P29.97 or is it because the speed is a bit too high?

Is the audio correct? Does it play back correctly?



Hi Gordon.

The audio sounds fine and the playback is okay but if I use the info button on the TV it says the refresh rate is 1080p/60hz when playing the file on the Slice. If played back on the Bluray the TV says it is in 1080p/24hz. The film I’ve been using as a test file is The Force Awakens so there is a lot of vertical panning and scrolling at the start that really shows the difference between the two sources.

I would’ve though if the slice was outputting 23.97 (or 24) fps that the TV would switch to that mode?



So that’s got nothing to do with the encoding then it’s all about the TV mode… First check that if you go to the setup and video the ‘change tv mode to match video’ is selected.

If not this could be the problem…

Secondly plug in a USB keyboard and whilst you are viewing the offending video press the ‘o’ button. This will display a bunch of real time information (buffer sizes etc) at the beginning of the third or fourth line it should give the media frame rate, check this says 23.97.

Finally if this is all correct then you are going to need to ssh into the box and do (while the video is playing):

tvservice -s

This will tell you the current video mode (I assume 60fps)…

tvservice -d dump.edid

ls -l dump.edid

Check that the file is the correct length… (should be 256 bytes)

then do:

edidparser dump.edid

And check for a 23.97 mode… Does one exist?



One thing I’ve noticed is that if you power up the Slice without the HDMI plugged in then it fails to read the EDID correctly, this means it will fail to find all the modes that your TV supports and will just default to 720P or 1080P

To avoid this you need to make absolutely sure that the TV is on and ready when you power on the Slice. I think it only matters when you power on the Slice it doesn’t matter if it goes into screensaver / standby.

So do try rebooting Slice while the TV is turned on and see if this fixes things



Cheers Gordon, I’ll give them a try today.

Thanks again for your help with this!


Hi Gordon.

I tried your last suggestion regarding the HDMI EDID as I had a suspicion that might be an issue and it was. I have a 4x4 HDMI matrix on the output of the Slice and it looks like it might be affecting the handshaking. I had isolated the matrix as part of my fault finding by connecting the Slice directly to the TV but hadn’t rebooted the Slice as part of that process so was still getting 29.97fps play back.

What did make me think it could be the handshake was that 24fps wasn’t available as an option in the XMBC system display settings.

I’ve reconnected the Slice to the matrix and my films are now playing back at 24fps :joy:

Interestingly the Bluray player is connected to the same matrix and doesn’t have an issue with presenting 24fps but the hardware inside it is obviously different.

I’ll just have to remember to connect the Slice directly to the TV if I need to reboot it again.



Out of interest is there anyway to override the EDID the Slice detects and force it the playback the frame rate of the film?


Have a look at the options for edid here