Bloody build updated to Kodi 15.1 - OpenELEC 6.0


The Kodi 15.1 build that is currently known as ‘Bloody’ is soon going to move to Nightly and subsequently to Stable once the OpenELEC 6.0 branch becomes stable.

This is about as latest as it can be but still have a modicum of stability, would be good if we can have a couple of people test the build




Thanks Gordon, as soon as it’s in my Nightly list will test it out :smile:


downloaded and tested 2015091221… plays music fine (analogue output fixed :smile: )
seems to be fine. Test some more tonight.
Looking good so far… clock still not showing correct time though.



Great thanks, will transfer this to Nightly soon and then to stable once OpenELEC 6.0 becomes stable


Hi Gordon,
Installation of 2015091221 (bloody) was very straightforward.
After installation all my libraries with artwork came straight back as though nothing had happened :smile:
Analogue audio did not work however, but after doing this:-

Either get into the box via ssh and do:
echo blacklist snd_bcm2835 >> .config/modprobe.d/disable-spdif-for-hd-audio.conf
Or use samba access from a Windows PC to open
And add the line
blacklist snd_bcm2835
This should make the audio come alive again (and make the LEDs work!)

It does, I especially like that when playing a video source the sound goes through HDMI but if I start a music track it switches to using analogue; I use “Kodi remote” and don’t want to have the tv on to be able to hear my music :smile:
I have noticed that if I enable the video MMAL player option, sound then only goes through analogue (if it’s selected) and doesn’t swap between analog and HDMI like the OMX player option does, is this to be expected?
When playing video all signs of the juddering that was happening when using the OMXplayer on some sources has gone, video playback looks good :smile:
The default CPU frequency after the update is only 700MHz is this correct?
I am getting some random flashes from the LEDs (various colours) while the Slice is doing it’s start up sequence LED pattern.
The RTC problem I was having, going back an hour after each reboot when there was no network connectivity, now seems to be fixed.
Otherwise looks good.
Regards Kevin.


@Gordon, I bit the bullet and downloaded first the nightly and then the bloody without any problems. The bloody took a fair bit longer to download and install.

Nightly: everything fine, except my Slice acquired the clock bug. Time started five hours behind, then moved back an hour after every reboot. Installing a timeserver only works until the next reboot, then the clock goes back again.

Bloody: again everything OK apart from the clock bug - no change.

I then went back to stable and - yes, the clock bug remains!! I didn’t have it before.

To be brutally honest I did not notice any obvious updates or enhancements, so I am happy to go back to stable for the moment.


I just tried and my SLICE shows only Nightly and Stable, I did update NOOS by clicking forward, do I miss something?



That’s strange, I’ve just tried again and it all seems fine to me…

If you’re happy wiping your settings / library then you could try switching from basic to advanced mode then back again to basic mode using the rewind button on the remote (or r on a keyboard). This may fix the problem…



It’s likely that the clock bug is actually due to a file that stays around even when updating…

One way to cleanly sort this out is to go to Setup -> OpenELEC settings -> System -> Reset System Settings to defaults

This will also wipe your library but won’t wipe any media




2015091221… build in use

Thought I would try a test, so did " Setup -> OpenELEC settings -> System -> Reset System Settings to defaults"

Found that the audio will not come via analogue. Had to resort to the “echo blacklist snd_bcm2835 >> .config/modprobe.d/disable-spdif-for-hd-audio.conf” you suggested after the previous bloody. Audio fine with this mod.

Clock still is wrong, my install uses a wifi connection at present.

Media still there and just needs the library rebuild.

Suggest anyone using slice on analogue will have a problem if they are not OK with ssh and linux-speak as they will have problems with making analogue work.




Fixed analogue, could try again although I’m surprised about the clock still broken… Can you ssh into the box and run this:

grep -r hwclock /storage/.config



and this is the response

Slice (unofficial) Version: devel-20150912210008-r21336-g2c0686f
Slice git: 2c0686fcb57ce539b77d2f4b4b7e13885ea85ad7
Slice:~ # grep -r hwclock /storage/.config
Slice:~ #

Let me know what you would like me to try next

Thinking about the clock, if eth0 connected then the ntp service will have an internet connection when it starts (I assume) but with a wifi connection does ntp try to do its stuff without an active network connection and just “give up” or get it all wrong, rather than waiting for an internet connection to become active?



and later… I got curious,
Set hwclock manually, then set system clock manually to same date and time (today). each showed the correct time when ‘data’ or ‘hwclock’ commands entered.
Set system time to equal hwclock -s for completeness.

then rebooted and time came back correctly (well CET, it is an hour out, but I was not bending my head around that right now, the aim to see if it survives reboot or power off without the loss / gain of an hour or so).

then powered off for less than a minute and the time came back correctly.

then powered off for 5 minutes and the time (and date) comes back correctly

Does this help explain the “funny things” where some folks have it OK and others not?

Is there any testing you would like for modify hwclock or system clock times and reboots to help? Let me know.

edit… thinking a bit more… do we need to wait for several midnight boundaries to see if it still works after a day change??



Hi Roger,
Since Gordon’s latest bloody, I haven’t had a clock problem any more, see comments above, 5th post down.
I’ve had the problem with the clock from the beginning, see bug reports on GitHub, hopefully I can close it now. :smile: Lets hope yours now stays fixed. :wink:
Regards, Kevin.


Yes I saw your post and wondered why I had a different experience with the same build. I have had the problem too, as soon as I went to a wifi connection where the media player is (new house, no ethernet cables yet!). I noticed that it seemed to occur after a midnight boundary. That is why I did a bit more testing / messing around. Clock did not work with previous bloody or this.

I suggest we leave it open for a day or so, and I don’t alter anything in the Slice here, just use it normally, then I can report back after (I suggest) two midnights. I thought of changing the clock to 23:45 to test it, but then it is artificial. Better to use ‘real time’ :joy:

Is this OK with you?

Gordon, is there a newer bloody than the 21050912210… build you would like me to download and test?



Hi Roger,
Fine by me, it’s been open since end of March.
Regards Kevin.


just had the hard drive lose visibility as reported elsewhere, left Slice on and went off to walk the dog came back and HDD “MIA”

I was playing Slice data via a pi running RuneAudio to a IQaudIO Pi Dac +. Came back, went to play more audio via PC Rune web page and it would not play.

ssh into Slice and got this
Slice (unofficial) Version: devel-20150912210008-r21336-g2c0686f
Slice git: 2c0686fcb57ce539b77d2f4b4b7e13885ea85ad7
Slice:~ # df
Filesystem 1K-blocks Used Available Use% Mounted on
devtmpfs 170184 0 170184 0% /dev
/dev/mmcblk0p5 163660 157884 5776 96% /flash
/dev/mmcblk0p3 3030800 99040 2758092 3% /storage
/dev/loop0 148864 148864 0 100% /
tmpfs 175104 0 175104 0% /dev/shm
tmpfs 175104 5028 170076 3% /run
tmpfs 175104 0 175104 0% /sys/fs/cgroup
tmpfs 175104 4 175100 0% /tmp
tmpfs 175104 572 174532 0% /var
/dev/mmcblk0p1 122596 30108 92488 25% /var/media/RECOVERY
df: /var/media/Slice-HD: Transport endpoint is not connected

Rebooted slice and all was back to normal. I have had this a few times

I notice this entry
Slice:~ # cat /storage/.config/
hdparm -S60 /dev/sda

I previously changed my setting to -S242 (1 hour) in case this was causing issues prior to testing bloody 2015061221… I have not changed it in the current bloody with the reset system settings to default I did yesterday.

Still something strange going on. Locked Files - Unable to delete or open folders [RESOLVED] refers




…several midnights later with power on and one with power off over night, the clock is fine. Happy for you to close the bug report.



@gordon, just to reiterate that I now have the clock bug. Having tested the nightly and the bloody, I reverted to the stable with the clock bug intact…