Bloody build updated to Kodi 15.1 - OpenELEC 6.0


Have you “Reset System Settings to Defaults” in the OpenELEC settings dialog?



I loaded 2015091221… bloody, clock bug remained, did the reset (as per Gordon above) and still had the clock bug. Then I set hwclock to correct time and system time to correct time (using date) then for completeness set the system clock from the hwclock (hwclock -s) and since then, the time appears correct as per comments earlier. So if you have issues after the “reset” try this.



It would be interesting to see if this results in it working, I’m not sure exactly how hwclock is supposed to work but it is integrated into the standard system to set the system time at startup and save away the time at shutdown…

Can you just confirm whether you are running off ethernet or wifi and whether it has any effect on the bug?
Can you confirm your time zone settings and whether setting the timezone to UTC makes any difference?




Bloody build update…

Bloody was updated around three days ago to include the standard OpenELEC update mechanism… What this does is:

Once every six hours or so your Slice pings the script to see if there is a new version of the build that is valid for your configuration (bloody, nightly or stable). The software gets this configuration from the installed_os.json file in /storage and parses the “name” key to get the type between the brackets. If you change this to something else it’ll check that instead.

If there is an update found it will notify you (this should happen on first boot and then when awake no less than six hours later) and ask if you would like to download and install it (or you can select it to automatically download and install, but it does it behind your back and you possibly won’t know why suddenly your box is being sluggish)

Otherwise you can go to Setup->OpenELEC setup -> Check for updates




Good to here, just checking once this will be out on stable version all stable updates will be done this way?

It’s good news will be easier for the newbies and inexperience people to use.


Yes thanks @Gordon, this is a great idea especially for non-programmers like me!


Yes when we move this build forward to stable then it will then work there as well…


Glad to see this feature added, as makes the update process so simple


downloading ATM will test later / tomorrow AM.

Did you want to update the bloody after some of us have downloaded this one, so that we can verify the update notifier works as designed? If so, let us know.



OK, I’ve updated the bloody update so you should now get an update notification…


updated to bloody 201509201036…
try check for update now: while OK key is pressed it displays the “Configure the host name…” message for a short while then either reverts to the System LH menu item or leaves the Check for updates highlighted.

Appears to do nothing else.

Then I did a soft reset of openelec

retested and is the same, both with standard and advanced settings.

I will look in the morning to see if there is an auto update message, and retest “check now”

BTW, I confirm analogue audio is fixed on this build.



OK, I thought I had updated the build and had meant to, but hadn’t actually copies across the right files…



when I try check for updates it now tells me current version “devel… -g8f72b7e” i.e. the full version string and then on next line: Latest Version: g8f72b7e
and asks if I would like to update now, selecting no cancels the screen and allows me to reselect check for updates. Checking for updates give back the version screen as above, every time.

Select YES from update screen response and I get a download progress screen with the file name “Slice-Slice.arm-6.0-devel-20150920114210-r2134” at that point it runs out of space in the display window, the remainder of the string is not displayed on the next line. Should it? I think the whole version number should be displayed as conformation it is different.

The download speed is 16-35kbps and the time remaining is 2-3 hours, a bit slow, I think! After the % progress at the top of the window “OpenELEC 2%” I cancelled the update. I was going to stop the update part-way through to test anyway. EDIT: using wired connection.

When I select Check for updates, I get nothing, even though the download did not complete, I think it should allow me to be told about the update as the install of the new version is not complete.

Navigating away from the OpenELEC menu back to the Main Icon selection strip and then going back to OpenELEC settings and Check for updates still behaves as if there is no update.

Reboot or power cycle restores the Check for updates function again, every time UNTIL I select YES and then reverts to no update shown as above.

I get no notification of available updates on reboot or power cycle: should I?

There was no pop-up window either having left it on and showing the system info hardware screen overnight (more than 6 hours)

I think that the “End User” support would be easier if the Check for updates function told you EVERY time, even after a cancelled (or failed or power lost) download, and only reset itself after the upgrade is completed. If it remains as is, it may cause confusion and a suggestion to “reboot” is not really fixing the problem.

Hope this helps, let me know when I can retest for you (including new build download and or OpenELEC soft reset).



Thanks for that,

Yes unfortunately that’s basically what OpenELEC does with it’s update mechanism, there doesn’t seem to be any hooks into the notifications (like screensaver on and off) and when the notification goes onto the screen it will only be there for a few seconds.

Once you’ve started updating OpenELEC assumes it will complete and therefore doesn’t let the update mechanism run again which is what you’re seeing.

I was thinking of adding something a little different, but it’s actually quite hard to do the right thing (just think what windows / macos do for updates, lots of dialog boxes and lots of options for timing / auto updates / auto checks etc)

Will think about it though




OK, I was thinking in my comments that it should really be “user friendly” as you would not expect a “end user” to be linux literate and understand the complexities of operating systems and updates. I have worked with hardware and software (many different OSs) for a long time, so I should do (oh! and I have written test scripts, test plans and regression testing procedures too). If we can’t make it automatic and simple, we will just have to explain the issue of cancelling / aborting / not completing and that a reboot is needed to get the manual check for updates back again.

What about the automatic checking / notification process, I have not seen that work yet. I will check again tomorrow and re-boot the Slice first then monitor it during the day.



I agree it should be really user friendly, unfortunately it’s not! I’m thinking of ways of improving it…

One thing you can try is the automated update, if you enable this then it’ll just do it completely automatically without even telling you, you’ll just find that it’ll install a new version the next time you reboot! But I don’t like that either, too much can go wrong



I don’t like automatic updates, as you say too much can go wrong, and would give a nightmare support scenario if it broke “end user” boxes. I think it should be advised against / disabled for that reason and the anti-social nature, as you said before, would slow the box down somewhat!

If you want to bounce ideas off me, feel free, either here or PM me.

If it proves a complex issue, it may be better leaving it with the “advice note” that a reboot is needed to restore the check for updates function, than waste too much time on it now. If we can’t simplify it, then better to leave it as-is. Is it something that the OpenELEC folks should be improving and should we be asking them to revisit the update process?

I do subscribe to the “if it ain’t broke, don’t fix it” support school: if the end user is happy with the functions, there should be no need to upgrade at all or very often, unless there are enhancements / additions which are wanted.



I have never had a issue with the auto updates, as it does a md5sum on both the system and kernel before replacing them your fairly safe from damaged downloads


If there was a way that you could have auto updates only check at a set time period would be much better, so you could set it to check for updates only after 2am and before 6am for example. The one thing that’s lacking is the notification to the user that a new version will be installed on next boot



I said I would report back about auto update notification:

After a reboot today, and leaving the box on and revisiting every so often, after 10 hours and 30 minutes there is no notification about available updates (well, no notifications at all). The manual check for updates works fine (after 10 hrs…) and says there is an update.

So check for updates works, but there seems to be no auto update “pop-up” message. Should there be?