Current method of installing Raspbian


Hi there,

What is the current best practice for installing raspbian on the Slice?

  • Have tried updating noobs and installing rasbian - results in not enough space error
  • tried flashing raspbian jessie lite onto the eMMC - results with booting raspbian but no USB or network
  • Also tried cross compiling the kernel using these instructions - results in the rainbow screen.

I am wanting to get raspbian lite onto several slices and wonder if the process could be as simple as the buildroot described in this post
Gordon mentions …

I also wrote a similar but slightly different programming Buildroot
kernel. This was used to program the Slice eMMC, copy data from a server
onto the hard drive, install the licenses, install the recovery system
and then boot into the Slice operating system to check everything was
working. This takes about one minute, but, because the whole process is
done automatically, it could be done in parallel.

Is there a working how-to for buildroot slice?
Is there another method that will work?
Am I asking the right questions? in the right place?

Love the slice hardware
Thanks in advance



For the moment I’m developing new documentation for this since the linux branch has not been kept up to date with the latest Raspberry Pi kernel…

Please follow these instructions to get USB/Ethernet working and then feedback results and I’ll give you further instructions



Hi Gordon,

Yay, got that step done, Many Thanks
I will await further instructions.




Continue with the linux building instructions now… I’d suggest cross compilation if you have an x86 linux box available to cross compile since it takes a lot less time, although direct compilation on the Slice will work and makes installing and the command line a lot easier but may take as long as 8 hours to complete!)



Getting thru it
Up to this …

ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- make menuconfig

get the following
> HOSTCC scripts/kconfig/mconf.o

In file included from scripts/kconfig/mconf.c:23:0:
scripts/kconfig/lxdialog/dialog.h:38:20: fatal error: curses.h: No such file or directory
compilation terminated.
scripts/ recipe for target 'scripts/kconfig/mconf.o' failed
make[1]: *** [scripts/kconfig/mconf.o] Error 1
Makefile:531: recipe for target 'menuconfig' failed
make: *** [menuconfig] Error 2

do I need the buildroot folder somewhere ? relative to the linux folder?



I discovered that “sudo apt-get install libncurses-dev” worked.
Took me a while … note to self don’t compile at 1am
carrying on


is this correct
I have made a mount points and usb mounted.
I run

sudo make modules_install INSTALL_MOD_PATH=…/mnt/ext4
gives me

  • Restart config…
  • Linux/x86 4.4.19 Kernel Configuration

64-bit kernel (64BIT) [Y/n/?] (NEW) n

  • General setup

Cross-compiler tool prefix (CROSS_COMPILE) []
Compile also drivers which will not load (COMPILE_TEST) [N/y/?] n
Local version - append to kernel release (LOCALVERSION) []
Automatically append version information to the version string (LOCALVERSION_AUTO) [N/y/?] n
Kernel compression mode

  1. Gzip (KERNEL_GZIP)
  1. Bzip2 (KERNEL_BZIP2) (NEW)
  5. LZ4 (KERNEL_LZ4)

So I ran this instead

sudo make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- INSTALL_MOD_PATH=…/mnt/ext4 modules_install

now stuck at

sudo scripts/mkknlimg arch/arm/boot/zImage …/mnt/fat32/$KERNEL.img

  • File ‘arch/arm/boot/zImage’ not found

Where does the zImage hide?


Assuming you build zImage previously it should be in arch/arm/boot/zImage

Did you successfully build the kernel correctly?


Hi Gordon,

Sorry bit of a noob with this compile stuff.
Is there a raspbian image pre-compiled somewhere?
If not I will press on with the compiling.

Here is what I run

ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- INSTALL_MOD_PATH=root make zImage dtbs modules -j12

I get

CHK include/config/kernel.release
CHK include/generated/uapi/linux/version.h
HOSTCC scripts/sortextable
CC scripts/mod/empty.o
CHK include/generated/utsrelease.h
arm-linux-gnueabihf-gcc: error trying to exec ‘cc1’: execvp CC scripts/mod/devicetable-offsets.s
: No such file or directory
scripts/ recipe for target ‘scripts/mod/empty.o’ failed
make[2]: *** [scripts/mod/empty.o] Error 1
make[2]: *** Waiting for unfinished jobs…
arm-linux-gnueabihf-gcc: error trying to exec ‘cc1’: execvp: No such file or directory
scripts/ recipe for target ‘scripts/mod/devicetable-offsets.s’ failed
make[2]: *** [scripts/mod/devicetable-offsets.s] Error 1
scripts/ recipe for target ‘scripts/mod’ failed
make[1]: *** [scripts/mod] Error 2
make[1]: *** Waiting for unfinished jobs…
make[1]: ‘include/generated/mach-types.h’ is up to date.
scripts/sortextable.c:31:32: fatal error: tools/be_byteshift.h: No such file or directory
compilation terminated.
scripts/ recipe for target ‘scripts/sortextable’ failed
make[1]: *** [scripts/sortextable] Error 1
Makefile:545: recipe for target ‘scripts’ failed
make: *** [scripts] Error 2
make: *** Waiting for unfinished jobs…
CHK include/generated/timeconst.h
CC kernel/bounds.s
arm-linux-gnueabihf-gcc: error trying to exec ‘cc1’: execvp: No such file or directory
Kbuild:44: recipe for target ‘kernel/bounds.s’ failed
make[1]: *** [kernel/bounds.s] Error 1
make[1]: *** Waiting for unfinished jobs…
Makefile:987: recipe for target ‘prepare0’ failed
make: *** [prepare0] Error 2

Where to next?



Hey @robingeek
Have you found a way to install raspbian on it?

What is the easiest way? I’m kind of a big noob when it comes to linux, debian etc.

I’d like to install pi-hole onto it.


Hi @chickendiner

I can get raspbian lite onto the slice with CM1 by following Gordonas instructions above.

  • use rpiboot to mount the slice eMMC
  • use something like dd to flash the raspbian lite image.
  • copy across the dt-blob.bin

It will now boot up.
I have not been successful with compiling the kernel stuff to get the LED’s working.

I have begun testing with a CM3, trying to get raspbian onto it.
I can flash the image but don’t have a working USB/ network stack.

@Gordon is there a different dt-blob.bin for the CM3?



Yes the dt-blob.bin is different, although the only real change is the top level is pins_cm3 rather than pins_cm as it was previously



Ok, and where do we find this new dt-blob.bin?



@gordon I’d also be interested in knowing where I can download the CM3 dt-blob.bin please?





Thank you Gordon