Disk always spinning


Even after its powered down the disk keeps whirring, is this normal?
Also, is it safe for me to take the power supply out of the back and back in so i can get it turned on if the disk is still spinning?


The disk should spin down if you have a recent version of the Slice operating system (originally we didn’t implement the spin down command)

What build date do you have, (go to setup -> XBMC settings -> system info and there should be a build date in the version in reverse order, something like 201604171352


its got 20150327072056


I would update to latest stable version using the recovery system, pressing the ninja button when prompted on booting


trying to update it, message showing ‘Testing md5 sumi’ is showing and has been for nearly an hour. what should I do?


Press Ctrl-Alt-F2

Log in username ‘root’ password ‘raspberry’

type noobs_update

When this finishes then wait for a count of ten and pull power

Should then boot back up…

When updating you pressed the wrong button, you should press the install button (or swap button) top left on the remote



I read that spinning down the disks is actually shortening their life. Is there a way to disable the spindown [it seems that the external disk connected via USB is stopping after a while] ?


So far I put this line in the autostart.sh

#disable spindown
(sleep 45; hdparm -S0 /dev/sda; hdparm -S0 /dev/sdb)&

Is there another/cleaner way ?


No that’s about as good as you’re going to get, although you could add it as a udev rule instead to match against /dev/sd[a-z]*



Ok Thank you !

A question how is the spindown implemented now ? Is there a call to hdparm somewhere or there is something else ?


Currently it’s implemented the same as you have done it, there is an autostart.sh in the standard build that does hdparm -s5 /dev/sda