Erratic behaviour by OS - I'm at my wit's end!


#1

I’ve been using Slice for a while now and I’ve found the experience to be be disappointing. I had very high hopes that this would be the media player to end the struggle, once and for all. For the record I have been using Popcorn Hour media players, Dvix player, Apple TV, Fire TV etc. Maybe Slice just isn’t for me?

  1. The OS just keeps throwing curve balls at me. One of my major media sources is an FTP server running off my seedbox. It was working fine…until it wasn’t. One day it just randomly stopped working. I would click on it to access it and the system would just hang on “loading…” and since there is no power/reset button I have to reach my hand in to the back of the media cabinet and unplug/plug Slice EVERY SINGLE TIME I have to reboot…and I have to do it a LOT. Since then I have tried to successfully/unsuccessfully up/downgrade between nightly, bloody and stable (which one is the one that works?). FYI I was on “stable” when it stopped working and it still does not work, despite several fresh installs.

Btw, when adding media source, if I add a folder within the seedbox as a video source…all the files within that folder play fine on Slice. But if I add the main root folder of the seedbox as the video source…the way it was set up earlier and was working great…it always hangs on “loading…”.

  1. Attempting to update the OS through the OpenElec settings is just a dead wall. Nothing happens. It shows “Update available” and then nothing. Is this a broken part of the code? Am I doing something wrong? I have tried to “force update” and it starts loading but then quits. Nothing.

  2. When attempting to update through NOOBS its mostly hit-or-miss. I literally have had to keep trying like 10 times before the update would just randomly work. When will “stable” actually be stable enough to work flawlessly?

  3. Trying to install additional skins or plug-ins almost 90% of the time gives a “not enough space” error. I have a freaking 1 TB HDD inside this thing!!! and I can’t install a 195KB plugin because there isn’t enough flash memory. REALLY!? Why can’t the OS access all that space? and if its not supposed to…why isn’t the system memory adequately large to accommodate things like plugins, skins etc? Isn’t that the whole point of Kodi?

  4. I have no Linux experience so I am not as tech savvy as a lot of users here who get around the issues by getting shell access and executing scripts. Can someone just tell me plainly how to make this work?

I am now on Kodi 16.1 thanks to the “nightly” version of Slice OS I have but I am unable to access my media from the FTP seedbox OR install skins/plugins. Please tell me what I am supposed to do with it or help me solve these issues.


#2

I think most of your problems stem from the fact that your /storage partition is low on memory (the library is stored there) you can check that by going to Setup -> System Info -> Storage and looking at /dev/mmcblkp3.

Available should be something like 2G.

The reason that we cannot put this on the hard drive is because the HDD is formatted as exFAT and the linux kernel cannot access an exFAT partition at boot time to access the setup files it needs.

It is possible to move the /storage to the hard drive, but this requires that the HDD is first reformatted as an ext4 file system (which will then wipe any media currently stored on the HDD).

Basically to do this you’d need to re-partition the HDD into two partitions, a 900G exFAT partition and a 100G ext4 storage partition.

Let me think about how I can do this, really simply

Gordon


#3

Ok great, waiting for your response. Can you also advise on what might the issue be with the FTP server connection getting stuck at “loading…”?


#4

OK,

Please note this is going to reformat your hard disc drive to make this change. You will lose all data from the HDD although you should keep your library settings etc. Even though you keep the settings I’d suggest resetting those as well just in case your FTP problem is actually caused by the files in there already.

First use NOOBS to go back to the stable build, as a non-expert I’d suggest you always stay with stable. It’ll be updated when there is a more stable build.

Next go to Setup -> OpenELEC Settings -> System -> Execute script

It will now ask for a sprunge based link, type in http://sprunge.us/JFXM

This is a bash script that does the following:

sd_dev=`find /dev/sd?`
sdcount=`find /dev/sd? | wc -l`

echo Found $sdcount devices

if [ $sdcount -ne 1 ]; then
    echo Remove any USB mass storage devices until only the internal
    echo hard drive is left
    exit
fi

echo Using $sd_dev

# unmount anything using it
umount /dev/sda? 2>/dev/null

echo Creating new partition label
parted -s $sd_dev mklabel gpt
echo Creating Slice-HD partition
parted -s $sd_dev mkpart Slice-HD hfs 4MiB 900GiB
echo Creating Storage partition
parted -s $sd_dev mkpart Storage ext4 900GiB 1000GB

partprobe

echo Formatting storage partition
mkfs.ext4 -F /dev/sda2

partprobe

echo Mounting storage partition
mkdir -p /tmp/disk
mount ${sd_dev}2 /tmp/disk

echo Copying storage to disk
cp -ar /storage/. /tmp/disk

umount /tmp/disk

echo Switching labels on $sd_dev and /dev/mmcblkp3
e2label /dev/mmcblk0p3 OLD
e2label ${sd_dev}2 SETTINGS

#5

Ok thanks I will try this. What should I observe next if this script executes successfully?
And how do I reset the settings?


#6

If everything works OK then you just need to reboot the box, to check everything worked OK just have a look at the

Setup -> System Info -> Storage

It should have a line saying

/dev/sda2  some sizes  /storage

The next thing to do (which I forgot in the above) is to format the 900G chunk of the hard drive, do this by plugging into a Windows PC or MAC PC and format as exFAT. This is probably the most reliable format you can use…


#7

I attempted to revert to stable version but this is what happens. Every. Single. Time.


#8


#9

And if you keep pressing “OK” button:

and it virtually stays like this indefinitely. So how do I switch to stable?


#10

I attempted the script from the nightly build, the system didn’t seem like it did anything so I rebooted. Here is the storage status AFTER rebooting. Unfortunately I forgot to take a photo of the storage before executing the script. I’m not sure if it worked because the some media stored on the HDD is still there after the script and reboot.

So what do I do now?

(sorry for the multiple posts as “new users can only post 1 image in a reply”)


#11

It’s possible that the files are still there because you didn’t reformat the drive and the old contents were still valid…

Go back to the System setup page and instead of the execute script, hit the paste debug to pastebin button. This should give you another sprunge link which should be filled with much debug…

Gordon


#12

Log files pasted to http://sprunge.us/XTZK

So is there any other way to revert to stable build or should I just proceed with current nightly?


#13

Also, you can see on the System screen grab there is no new 100G partition being created as should have if the script executed successfully. The external storage still shows 931G.

The internal memory is also 100% used which stays this way despite multiple reboots. Any advice?!


#14

It looks like the script is failing (as is the paste of debug) because there’s no memory available!

I would suggest going into your OpenELEC settings dialog and under System again choose “Reset XBMC” option to clear up some space first.

Then after rebooting, check you’ve got some space available and if everything is fine then run the script again…

Gordon


#15

Ok I soft reset XBMC and that got space freed up.

Ran the script again, now I have this:

Debug log at http://sprung.us/GNaE
What do I do next?


#16

OK, next you just need to format the first partition as exFAT. I’d suggest doing this on a Mac or Windows computer, just power off the slice and unplug from DC jack, then just use the supplied uUSB Y cable to plug the uUSB connector on the Slice to a PC or Mac.

It should automatically ask you to reformat…

I haven’t tried this yet, the partitioning should be correct though

Gordon


#17

Looking at the partitioning of the hard drive I don’t think it’s right, it’s probably best to run the following script

http://sprunge.us/BZYi

The only difference is the creation of the partition with type ntfs rather than hfs… This should then be formattable with a PC or Mac…

Gordon