Hard Drive keeps unmounting during library update


Had no issues with my slice so far, apart from trying out the nightly build and finding it slightly unstable, so switching back to Stable.

Tonight I put some new media on my Slice. I plugged it into my Windows 10 machine, and discovered a corrupted folder in the Movies folder.

Ran chkdsk /f and was then able to delete the folder.

Put the media on & ejected the Slice.

Plugged it back into my TV, and now, everytime I run Update Library I get the message “Mounting Removable Hard Drive” and then all my files and my mount point disappear.

If I don’t update my library everything is there and works normally (except for the new files of course).

I’ve tried plugging it back into my PC (got a “this disk has errors” message) - ran chkdsk, properly ejected etc. but still every time.

It’s odd because the message definiteyl says “Mounting…” not “Unmounting…” & yet everything disappears.

Any advice please?

It is currently usable but can’t add anything new to it…



P.S. Dont’ know if it helps or matters but one of the things I added was a whole bunch of custom tv episodes with custom nfo’s & jpgs.


Anyone got any ideas? (Or is it a case of start from scratch?)


The same happened to my slice, anyone know why this happen?


I couldn’t find a solution.

In the end had to rebuild my Slice & start from scratch. It’s been stable since then though.


I did the same, now is working fine.