HDD suddenly disappeared / un-mounted [RESOLVED]


#1

Any thoughts on this one…

My internal drive (2tb Samsung) has suddenly vanished without trace.

Been fine for the couple of months I’ve been using it, but has now gone. I’ve ssh’d, ran parted -l, and it’s not listed here (and that’s not far off the limit of my *unix based troubleshooting knowledge!)

It so happens that at the time I was trying to transfer some file my Synology nas to SLICE via DS File Station, where I’d mounted the SLICE drive - not sure if that was a cause or just triggered something that was going to happen anyway.

I self-formatted the drive - exFAT I think, but been fine till now


#2

You’ve done a hard reboot?

If that doesn’t work, does your PC see the drive when connected by USB? Have you checked the drive using the manufacturer’s software?

If still no joy, I would take the drive out, put it in an external case, and connect it to your PC. Any error messages would help us diagnose your issue.


#3

All seems to be ok now…
Hard resetting didn’t do anything - plugging it into my PC allowed me to see the drive file - but slice still wouldn’t see the drive when booted up.

Went back to my pc again, but this time moved some data on and some off the drive to ensure I could actually access the data, which went fine.

After this, slice fired up as normal, and sees the drive and the media on it as if nothing had happened.

Be interested to get any thoughts on this, and whether something in the process of mounting in within Synology could have triggered this or if it was something else and a coincidence.


#4

There have been other reports of drives unmounting, see here:

Those involve WD Blue disks specifically. Over the months I have personally had a couple of times when the drive seems to disappear, always cured by a hard reboot, so I have always put it down to the classic ‘lock-up’ that all electronic devices seem to suffer from time to time.

I’ll mark this as resolved for now (or self-resolved??!!)


#5

yeah - if nothing else it can be a reference post should it crop up for anyone else


#6

I have a 1TB WD Red in my slice and I’ve notice exactly twice.


#7

My Slice with the Ninja installed 2 TB drive experience this tonight, i.e., the Slice-HD vanished. Looking in Files > only showed

TV Shows
Videos
Add Videos

No Slice-HD. And no Slice-HD seen on the network.

And because the link to the Slice-HD “disappeared,” the links to the tv shows and movies was screwed up. I cannot explain how it finally re-appeared but THANKFULLY it did. I did have a backup created of the metadata, etc. which I recommend that every user create.
Setup > Open Elec Settings > Backup (something like that).

That other problem I had with the time settings has not happened again even with powering of several times.


#8

I just saw this on my Slice for the first time today. Today was the first time I connected my Slice via USB to a Windows 10 system to update the files. I can see everything on the drive fine in Windows 10 but when I connect it to the TV again it cannot mount the internal drive.

Could this be a cause? I have still not been able to get the Slice to mount.


#9

Reconnect the drive to Windows 10 and check for errors. Then make sure that you ‘safely eject’ the drive before pulling out the USB cable.


#10

I have it back on my Windows 10 machine doing a backup right now. Once it gets done I will try that and let you know what I find.

Are there any commands you would like to see the results of after I finish if the drive does not mount? I can include the output later if needed.


#11

Ok, I have the Slice back up again. Here is the parted output for my drive in the slice. As you can see the drive is there and recognized. I performed a file system check in Windows and everything is clean.

Model: HGST HTS 721010A9E630 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 1000GB 1000GB primary ntfs

I found these instructions for mounting the drive. Where do I create the mnt directory? I can’t do “mkdir /mnt” since root is read only.

mkdir mnt
sudo mount /dev/sda1 mnt


#12

I am also starting to see this happening a lot.

The drive just seems to unmount and with normal reboot sometimes comes back but usually doesnt. Even hard boot sometimes doesn’t fix it.

Only way to get it working again is to connect it to my Windows 10 machine and use chkdsk to fix the error (which there are lots). I have already once formatted the drive and started from scratch and it fixed it for a while but now this is starting to happen again.

Also When i connect the box to my Win10, i actually cant see any “safely remove this drive” option like usually with USB drives…


#13

My Slice (which has already had one return trip to the dojo) does the same. It unmounts after a few minutes when I try copying files via a samba share, and after using it as a usb drive on my desktop a few times (which is the only way I can transfer files to it), I can’t mount the drive. I’ve done repairs (chkdsk) and unmounted safely, and soft and hard resets does nothing. So now I have a fancy streaming box with a wonky remote and random lights. Hope you guys can figure out a solution.


#14

Mine Happened again last night when rebuilding Library 2T samsung and latest Slice Build time to reformat again!


#15

Did it start happening after powering off the Slice?

Can you go to Setup -> OpenELEC settings -> System -> Paste debug to pastebin

and send me the resulting link?

Gordon


#16

I would suggest (because I just saw this problem and made it go away)

Plug it into a Windows computer, open the disk and make sure everything is correct

The next step is the most important of all…

Eject the disk

Finally unplug then plug in power and reboot as normal


#17

That worked but can we make it not happen?


#18

Not right now, the most important thing is to treat the disk with care and make sure you never power off Slice without it first having been shutdown. And make sure you eject the USB drive before unplugging

Gordon


#19

This just happened to me. Brand new slice been installed for a month or two. Music originally transferred via USB but it had been happily working under the TV for a month without issue.

Randomly the HDD disappeared. To be really clear, the device had not been powered off, or in fact touched at all beyond using using the remote to play music, so whatever cause the problem meaning the HDD disappeared it wasn’t a bad power off or bad unmounting from Windows?


#20

Have you updated your Slice recently? I would suggest you update to Stable (just hit the top right button as it powers up)

After doing that I’d suggest plugging it into a windows PC to check and fix the exFAT disk (you may have lost some media so probably best check)

Then power it up normally again and try again… I’ve pushed a patch to the disk driver which should make it more reliable, but currently I don’t know if this is the cause or not…

Gordon