HDD suddenly disappeared / un-mounted [RESOLVED]


#41

@Gordon well the issue has also happened on a standard build of OE, caught a trace this time

http://sprunge.us/jOFV


#42

Can you check that it’s not environmental, maybe leave at work for a couple of days or someone elses house, just to check it’s not a real EMI spike causing the problem.

If not I think you’ll need to return it so James can have a look at the hardware to understand…

I assume you’ve definitely reproduced this on a stable SliceOS build as well?

Gordon


#43

I will flash the latest Stable now and leave it for a few days and see if the issue happens again, if still getting the issue i will swap with my DEV slice and see if that gets the issue as well. the problem is it only happens when watching movies it would seem, as if the system is just left idea i cannot seem to get the issue


#44

Don’t bother switching to the DEV slice, we already know it’s not a problem generally with everyone. So there must be something specific different about your hardware that is triggering the problem.

One thing it may be worth doing is switching to exFAT. That is one thing that is different between your HDD and others, again just trying to ascertain what is effecting the error…

It’s interesting that it requires the data to be playing back… Is that just on the local drive? What if you play back video from a file server or something? (or a locally connected flash drive)

Gordon


#45

Well thats the even stranger thing, all content is being played over NFS, there is no local content on the disk


#46

http://sprunge.us/VXCL

Same issue on standard build


#47

Hi chaps, sorry to butt in. Just to let you know that I’m using EXT4 and apart from the problem I mentioned a few posts back (about post 24) which I fixed by changing my shutdown.sh I’ve not had any problems since, either standby or playing media. All my media is played from the disk I don’t have one of those NAS things :wink: Also my Slice always gets powered off over night.
I do still get the random, usually green LED, on the left side however that Mike mentioned a couple of posts back, along with random flashing when the LEDs are actively doing something.
Regards Kevin.


#48

Ok, so as i am in the office today i was testing with the dev slice

not the same error as system at home, but the hdd has disappeared

http://sprunge.us/cVDZ


#49

It’s interesting that the device has been ‘offlined’ I’m not sure what this actually means, but I’m wondering whether the disk is going into a sleep condition or coming out of one when the problem occurs.

Did it happen whilst playing video again?

Might be interesting if you change the hdparm setting to stop the disk from going to standby ever. Just to see if it’s something to do with pulling large currents when spinning up the disk

Gordon


#50

Well so far i think i might have fixed the issue with the EMI error, i have replaced the HDMI cable that came with the Slice with a different one and so far not issues to report


#51

That’s very interesting, although somewhat surprising, would be interesting if you can definitely reproduce reliably…

If so I’d like to see that cable, it may have some failed shielding…

Gordon


#52

Not used Slice for a few weeks until adding some stuff via usb into macbook. After plugging back into tv I found the SliceHD path no longer visible so I can’t access my library even though it still shows when plugged into macbook. After looking through the forum i’ve tried rebooting, updating to the latest stable build and repaired disk on macbook using disk utility. Still no success.

Any ideas on what else I can do?


#53

Go to Files -> browse -> root filesystem -> media

Is there a Slice-HD there?

Gordon


#54

The only thing that shows up is a usb memory stick i’ve plugged in.


#55

Can you go to

Setup -> XBMC settings -> debugging -> enable debug

then, reboot the box… then

Setup -> OpenELEC settings -> System -> paste debug to pastebin

Then post the web link it gives you here

Gordon


#56

http://sprunge.us/DWOW


#57

OK, only thing missing is the dmesg log which may tell us something, if you’ve got ssh set up, then log into Slice and type

dmesg | paste

This should again give you a link


#58

So far still no issues, if fine till the weekend i will get the cable to you, also i tried that cable on a set-top box and i was getting a breakup in the image, like pixelation.


#59

The only problem is that i’m a complete novice when it comes to ssh. I know i have to go into terminal but that’s about all i know!


#60

Fair enough I was going to add a backdoor for doing this kind of stuff, will need to test first though…

When you plugged the disk into the Mac did you properly eject it afterwards?