HDMI Handshake? (ANSWERED)


I’m wondering what’s happening when I start the playback of a video file, it feels like my slice is doing some kind of HDMI handshake.

What happens is that initially I get both picture and sound, then after a split second, both cut-out for a short time before the picture comes back followed by the audio.

Through out this, the playback continues, so the result is often that you rejoin mid sentence, not really knowing what’s occurred while the handshake is taking place.

Not a massive problem I know, but I’m just wondering why it happens during playback rather than before it, and whether there’s anything I can do to improve it?

Cheers, Matthew


It is probably the HDMI changing output mode to match the video source. The idea is if you’ve got 24fps video then it’s best to play it at 1080P24 because then you don’t end up continually skipping frames. Whereas when you play a 720p50 then 24fps would have you skipping again. So when you start the video Kodi identifies the best video mode to select and uses that.



Okay thanks for that Gordon, I can see why changing the output to match the playback is required.

What I don’t quite get is why Kodi is doing this once playback has started rather than ‘looking ahead’ and getting it setup before the playback starts. I know I’m comparing apples with oranges here but when you see playback on Bluray/DVD players they get it done beforehand.

Is there a way to get it to look ahead or delay the start of the playback so that the handshake doesn’t get in the way?

As this seems to be Kodi specific rather than slice, should I be asking about this on a Kodi forum rather than here?

Cheers, Matthew


There is a setting in the video setting to pause the video X number of seconds. This is the fix for that.


Hi @bertybassett thanks for replying. Yes I have had a play with a couple of the settings and the pause setting does improve it - though I still find it a little jarring when it does a start/pause/start.

What I’ve realised is that 90% of my media is actually the same refresh rate, so I’m trying out the ‘switching off’ of the auto sync refresh rate and setting the default refresh rate to 50Hz (PAL).

This seems to flow nicely between the menu and playback, the downside is I have to remember to manually switch it for the last 10% of my media, but so far it seems to work well for my needs.

As my media becomes more diverse I can see me having to go back to the auto sync though.



There is another setting for

start /stop only



That’s what you need to play with.