How do I update Slice? (ANSWERED)


Hello all, Linux Noob here. I’ve been waiting for an update for slice for sometime now. I’ve assumed the auto update function would update my slice to the latest software, however this is not the case. I am curious what do I need to do in order to update my slice with the OpenELEC or if I even need to use it. There is a new build 15.2 with OpenELEC 6.0. Wanted to give that a go. Again, I am new to linux so don’t assume I know everything haha. -Steve


Ensure you are connected to the internet over ethernet and NOT wifi.

When you start the system up and see the ‘Slice’ logo, press the Ninja button (right top corner) once. You’ll enter the screen where you can update the operating system.

Hit the fast forward button (right bottom corner) to update NOOBS system. The system will restart. Hit the the Ninjas button again to enter setup area.

With the Slice (stable) checked, hit the button on the left top corner. And the system will take care of itself.

Let us know if you encounter any issues. Have fun !


tried to install openelec to install bloddy and now I’m at a black screen with a debugging that failed.


maybe someone can get on call with me to help guide me through this :frowning:


what does the screen look like?

I would suggest that what you should have done is just to install the stable option from within the recovery system. Depending upon when you got your slice NOOBS should not require updating (last change was about six months ago)

Did you accidentally switch to “Advanced mode” which means you had about six or eight different options including Raspbian, OpenELEC etc If you did you’ll need to switch back to basic mode by pressing the rewind button…



I fixed it… I wasn’t entering recovery mode screen correctly or something lastnight… I installed bloody 15.2 and it’s running great!.


maybe you pressed the OK button more than once when attempting to select recovery mode (or got extra presses as reported elsewhere as an issue). I found this. The first press goes into recovery mode but takes just a fraction of a second longer than you think is right to give you a mouse pointer arrow in the middle of the screen, so the mind says ah! need to press the key again because it did nothing the first time… and the second press takes you out of recovery mode again and boots the Slice !!!



Just Updated to Slice (stable) Kodi 15.2
what are the differences between Stable- Nightly and Bloody ?


Right now there are no differences.

stable == bloody == nightly

But there will be an update for you again, since I just pushed a new stable build…


Help! All media disappeared. Tried update to 15.2. Says ‘testing md5 sumi (safe to power off / reboot)’. Cancel button available. What next?


You are trying to update the recovery system (NOOBS), you should be very careful doing that.

I’m not sure why it isn’t working, but make sure you’ve got ethernet plugged in before trying to update, then select stable and hit the top left button on the remote to update the Slice installation.



that just fixed my HDD not showing up, thanks


how did you get it to work, I am stuck at 14.1 recovery doesn’t give me any options


It’s not a fix for old noobs issues, but describes how to start over with LE and a clean install.