How to return faulty item


Please email for details. Ensure you specifiy the faulty component and describe the nature of the fault.

The mods would be grateful if users could avoid cluttering up the forums with return enquiries. Any separate posts re returns/faults will be moved into this topic.

No response from support about non-working remote


I haven’t got a response from that address in months.
Either “dojo” is submerged in work or … nonexistent.


Continuing the discussion from Remote Control Failure:

Hi guys,

I have the same issue. I went and replaced the battery but still didn’t help. I have to keep on meddling with the dongle after plugging it in to make the remote work.

Can we please have a resolution for this please?

Thank you


@edefault, Walther sorry about this - it was an email I found elsewhere on the forum that is supposedly for returns.

I have asked the FiveNinjas about it and will let you all know the outcome.


OK, I have checked, and the address is definitely the right address for returns.

UPDATE - please note that from now on ALL returns/faulty/DOA posts will be closed and moved into this topic.


I know some are going to be unhappy about this post, and everyone absolutely has a right to expect a fully-working remote, but a lateral way round this is to unearth an old IR remote and use it instead.

Just load the Keymap Editor official add-on and program the buttons. It gives you way more buttons to play with than the Slice remote as well.

Guide is here (this section really applies to all IR remotes):


Ok, so I’ve been having intermittent problems with my remote … it started slowly (didn’t work now and then and unplugged it or reconfiguring it worked) then became works. At one stage plugging it into my Mac and testing it before returning it to Slice solved the problem.

Now however doing that only works sometimes and basically works for a couple of clicks before it stops working. I’ve seen a few posts (and posted a one myself) but there doesn’t seem to be a conclusive fix. At home (I’m living abroad currently) my slice is controlled quite well by my Harmony Ultimate which is pretty great (apart from the fact that back doesn’t work).

Just an FYI, if anyone has an Anymore (also kickstarter I think), you can set up a Kodi remote there pretty easily and it works great on a SmartPhone. Just an FYI.


Hi guys,

I was one of the original kickstarter backers, and I’ve been so pleased with my slice I bought a 2nd one to give my parents for christmas. I’d loaded it up with content and scraped all the metadata (plugging it in where my existing slice is) to save me unpacking everything from the main box - since it was so neatly packaged!

The problem with me doing this is that it means I didn’t find out that the unit has got a faulty power supply unit until this morning :frowning:

It appears that if I jiggle the adapter in the socket the slice gets tiny bursts of power but I’m concerned about damaging it if I do this again. It looks as if the clip-in 3-prong UK connector isn’t connecting properly.

Is there any way I can get a replacement power supply? I’m donating my power supply until I can get a replacement - but didn’t want to wait too long. Has anyone else had this problem? If so, is there a simple fix (maybe by bending pins or something)?

Cheers all.


mine died this morning as well, i sent fiveninjas a email for replacement
hope they will reply me soon


Yes I am using the European adapter indeed. The only converter I could get my hands on is a deep socket (not flat) so it is impossible to use it with the adapter.
I have tried to plug it in again and fumble with the adapter, but still no sign of life.
However, after I had it plugged in for some time the bottom of the slice was feeling warm especially where the power connection is located in slice. So something must be happening.
Is this any help?


I would guess that the fuse has blown on Slice or the diode at the input. Are you sure you didn’t plug a different DC jack in by mistake?

I think you’ll have to return it to diagnose. Please email for details



Is the remote covered by some kind of guarantee…?

Got my Slice in May via kickstarter and the remote died in November…


I sent emails to dojo@ and jon@ and never heard back :disappointed: I ordered two weeks ago and my unit hasn’t shipped. I wonder if they’re still fulfilling??


After a ten day wait I have just received a new Slice. Plugged it into to PC, copied some media files to the HDD, removed connection from PC, plugged in HDMI, remote receiver, WiFi dongle and power. I get a colour gradient screen followed by a couple of other Kodi screens then the setup screen asking what language I want. I press all the buttons on the remote and nothing happens. I’ve checked there is a battery in the remote. Is there an LED on the remote to show it is working? I cannot see one when I press any of the buttons. What could be wrong?

Also, one of the rubber feet is missing from the bottom of the case - very annoying.


You could try plugging in a USB keyboard to see if it works with that. In that way you can work out if the problem is with the Slice or the remote (I’m guessing it’s the remote). The Kodi keyboard layout is here:


Thanks for your reply.

It works with a USB keyboard plugged in so I guess its either the receiver or the remote. I will email five ninjas and ask for replacements and a new foot.

Not exactly a brilliant experience so far.


There is a very (very) small led at the top center of the remote.
It lights up blue very faintly when a button is pressed.


E-mailed dojo twice, 18:th and 26:th of january about my remote that´s no longer working.


I sent also an email to dojo at the end of November 2015 but nothing happened, maybe it’s redirected directly to the bin / ignore folder