Installing mhddfs


#1

I found lately that there is this program mhddfs that would be able to create a virtual directory such as movies that will span across multiple disks.

There is a topic here http://openelec.tv/forum/65-storage/66686-guide-mhddfs-storage-pool-for-multiple-drives that provide 2 executables, tried them and do not work. [I guess that executables on the forum are for X86 while we would require an ARM version]

is t here a way to install this program on SLiCE ? Or is there anything around that would do the same ? As far as I understood the mhddfs program will take care of distributing the contents in n-drives just moving to the next one when one is full.


#2

If you’ve got a Raspberry Pi then you could build it on there and test it. You could then copy it across to your Slice easy enough

Gordon


#3

As I don’t have another spare raspberry Pi, I tried to create install mhddfs on on a virtual raspberry system using qemu.

UPDATES: managed to install mhddfs on a version of raspbian using qemu. I had to use the correct kernel that would match the /lib/modules version. Will try to copy the generated mhddfs executable in Slice to see if any joy.

The issues below where due a wrong kernel image used:

It seems that I got stuck when trying to install fuse with this error:

Setting up fuse (2.9.3-15+deb8u2) ... Creating fuse device... /run/udev or .udevdb or .udev presence implies active udev. Aborting MAKEDEV invocation. chmod: cannot access '/dev/fuse': No such file or directory dpkg: error processing package fuse (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: fuse

What I did so far:

Got a copy of the Jessie Lite from : https://www.raspberrypi.org/downloads/raspbian/
Use the kernel : kernel-qemu-4.1.7-jessie

Following the instructions here: https://github.com/dhruvvyas90/qemu-rpi-kernel/wiki/Emulating-Jessie-image-with-4.1.x-kernel and manged to get a bootable system.

trying uname -a gives:
on qemu raspbian:
Linux raspberrypi 4.1.13+ #2 Sun Jan 31 11:02:27 IST 2016 armv6l GNU/Linux

on slice: [nightly version]
Linux Slice 4.4.6 #1 Mon Apr 4 21:27:23 UTC 2016 armv6l GNU/Linux

Ok I am stuck here, any idea ? Seems that I cannot pass the fuse installation problem


#4

Following my last post, I managed to compile mhddfs in the QEMU image.

I put the executable in slice and all worked out. I am adding here the excutable file in case anyone wants to try it out : https://www.dropbox.com/s/hkktmomcblu4yw8/mhddfs?dl=0.

Made some tests, copy a 400Mb file over wifi and samba:

directly to the disk: around 3m:30s
over a mhddfs virtual mount: around 4m:50s

To mount on 2 separate disk I used:
mhddfs /media/internal/videos/movies/,/media/external/videos/movies/ /storage/movies/ -o nonempty