LibreELEC 8.0.1 is out... (CM3 improvements)


#1

source: LibreELEC 8.0.1 based on Kodi 17.1 is out!

one of interesting changes from change log:

  • improved software HEVC decoding on RPi3/CM3 hardware

Kodi 17.1 is released on 21.03.2017.
LibreELEC 8.0.1 is released on 24.03.2017.

check always up-to-date OpenELECT builds here http://chewitt.libreelec.tv/slice/ which already have 8.0.1 Slice3 builds, released on 25.03.2017. :slight_smile:

Cheers


#2

I’d like to update my CM3 Slice - what’s the quickest and easiest method from the previous OpenElec build?

Thanks in advance!


#3

I did the upgrade but haven’t really tried it out.
I didn’t know about the HEVC improvements. I still have some videos that were not playing nicely with the CM3, maybe this will solve it. I will report back.


#4

what u mean by not playing nicely? which format/encoder was used for these? Did they work good on CM1?


#5

After a bit of digging I’ll try and answer my own question!

Am I right that I need to ssh into the Slice, and copy the new .tar file into the update share? Rebooting Slice will then update?

I’d like clarification please as I currently have a working Slice and I’d like to keep it that way.

Ideally I’d like to be able to update like Noobs used to work, or at least just using the Slice. I’ve tried turning on automatic updates in the LibreELEC settings but that doesn’t seem to do anything…

Any advice from someone more knowledgable would be gratefully received.


#6

@shutterbug

Yes that it: copy the .tar for the CM3 module (you did download …slice3 file?!) to the .update share / directory and reboot.

The reboot process detects the file in .update, checks it is not corrupted (downloaded OK) and that it is the correct file for the hardware it is about to install. At this point you will see messages on the screen if anything is wrong, it will then wait a while and reboot back to the previous (working!) version, no damage done!!! ***

If all is well with the file the update process then displays messages about unpacking the compressed files, tells you it is installing them and then reboots (after a short wait to let you read the messages :).

All should be fine and you should have the new version working fine.

*** I had a bad download for the CM3, it said the file was corrupted so I downloaded again and used that file, it updated fine.

Report back success, please :slight_smile:
Roger


#7

H264 Hi10P 10B 720 are what I usually have (anime mostly). You can watch them both on the CM1 and CM3 (on the CM1 if you had heavily formatted subtitles it crashed sometime, not seen this on the CM3) but there are some trouble with colour gradients and macroblocks (still watchable).
I actually tried my first 4:4:4 file the other day (so I suppose Hi444PP because it is the only one supporting that level) and this one would not play at all (watching screen with the “hourglass” symbol in the middle getting filled constantly to 100% but nothing displayed).
Do you want some samples?


#8

Or not success, as in this case… :joy:

I did as you suggested, with the Slice3.arm-8.0.1.tar file.

It extracts, but when trying to install it says the update is not compatible with Slice2.arm hardware, and the install cancels.

I do have an upgraded Slice with the CM3, so what am I doing wrong?


#9

@shutterbug

have you downloaded the PI image by mistake?

this is the one for the CM3 Slice: LibreELEC-Slice3.arm-8.0.1.tar

this is the one for the Pi 2/3: LibreELEC-RPi2.arm-8.0.1.tar

this is the link for the Slice downloads http://chewitt.libreelec.tv/slice/

Can you confirm which one you have used?

Roger


#10

Hi roger,

Thanks for the speedy reply!

I’ve definitely downloaded the Slice3 .tar file.

I’m upgrading from the original installation on my CM3, which were Slice2 files, as per this post on Jan 18 from Gordon:

"So now you’ve got access to the eMMC you need to write the LibreELEC build onto it…

To do this, you just need to install the installer from LibreELEC

https://libreelec.tv/downloads/59

And download the slice build from chewitt’s builds…

http://chewitt.libreelec.tv/slice/68

So you need to download the ‘Slice2’ .img.gz file and extract the .img file from it. Then point the LibreELEC installer at the .img file and at the Slice mass storage device

Gordon"

So have I been using the wrong build all along?

Thanks - Roy.


#11

as per here

touch /storage/.update/.nocompat


#12

Thanks Mike. It seems I must be one of the “5 or 6 people affected” :tired_face:

Trouble is, the instructions there are all Greek to me, I’ve no idea how or where to run that in order to fix the problem…


#13

@shutterbug

Roy, MikeBuzz beat me to it, I had to look for the post https://forum.libreelec.tv/thread-1893-page-6.html Post number 85

Just create the file as per the post and put the updated .tar in the directory and it will be fine, thats what we all had to do at least once.

Slice2 was the old name which was before the module became “CM3” to be compatible with the Pi 3. the CM upgrade was planned for the Pi 2 CPU but the Pi 3 CPU came out and they decided to wait and use that one.

Quick reply… just sat down for a cuppa after a hard day grovelling in the loft space and saw your post, glad to help.

Roger


#14

@shutterbug

SSH into the slice and copy the string in the other post, the bit between the " marks. “touch” creates an empty file. The update process then sees the file and ignores the reported hardware compatibity “problem” and installs the updated version.

re 5-6 people… that was for the lucky beta testers who had an early release CM3 for testing (I did not :frowning: ). So we all have to overcome the hardware “issue”!

Roger


#15

Thanks Roger & Mike.

I’ve finally managed that :joy: And I’m now on 8.0.1.

One final question, if I turn on Automatic Updates in LibreELEC settings, will that now work in the future?


#16

@shutterbug

Well done, not too difficult once you know how to decode all the “Greek” :smile: Glad to help. I did not know all this stuff a while ago.

Auto updates: I let it notify me, I tend to be a bit wary of auto updates (no insult intended to those here or over at Libreelec) and subscribe to the ‘if it aint broke don’t fix it’ club. Probably caused by years of working for a large UK bank and also having the Microsoft Update Experience ™ over a number of years. :anguished:

I have a main Slice and one I use for testing before updating the “production Slice”.

Roger


#17

Thanks again Roger, good advice regarding the auto updates. Duly turned OFF!

Cheers,
Roy.


#18

And now awaiting release 8.0.2 for Kodi 17.3 which comes with security bugfix

Regards,
Klagh


#19

and it’s out https://libreelec.tv/2017/05/libreelec-krypton-v8-0-2-mr/ :slight_smile:


#20

The Slice build is not out yet. http://chewitt.libreelec.tv/slice/ still has links only to 8.0.1. And auto update isn’t getting excited about 8.0.2