LibreELEC (Krypton) 8.2.0 RELEASE is here


The beta has ended and as per the relase notes “PLEASE READ THE RELEASE NOTES below before posting an issue in the forums as there are disruptive changes to Samba, Lirc and Tvheadend.” from here The release of 8.2.0 is available from that link.

It also contains the fix for the KRACK WiFi issues recently publicised.

Please note the release note warning and remember to download the correct version for your Slice CM1 or CM3 :slight_smile:



I think a slight delay for Slice owners has been introduced:

“UPDATE (29/10): An issue with HEVC playback on Raspberry Pi and Slice hardware has been found after release so update files have been removed while we investigate the fix.”


… for which an update has been released (same link) as which downloads and installs OK on a Pi 3 and on a Slice CM3. Only tested playing music though :slight_smile: Manually updated BTW.



That didn’t take long for it to be sorted out!

There doesn’t seem to be a .tar file to update with?

Does it need to be a full reinstall using the USB-SD creator?


I have found the .tar file - its in the Slice specific (selected) downloads page

Thank you for the update


All seems good on a .tar manual update to for CM3.

It did take a couple of goes as it failed a checksum the first time.

I shall now attempt the other Slice, still on CM1


Happy to report the CM1 works as well.
(Obviously still running noticeably slower on menus and time to get to play back)

Thanks for this update as well!


Successfully auto updated CM1 where new .tar file had already been downloaded. I only needed to reboot and was installed. Am now listening to music player.


Finally updated my Slice to a CM3 and flashed with this release - running really smoothly, thanks for keeping the platform alive. Running cool enough with the top removed, heatsink (cut from length of 12mm copper busbar) to be fitted tomorrow.

One benefit is that this LibreELEC release now supports the great value Xbox One DVB-T/T2 tuner (£5-£10 on Amazon UK - eg here: ) turning the Slice into a very capable PVR which works fine with the UK Freeview HD channels. I needed to re-format the disk to ext4 from exfat to remove the dreaded TVHeadend transmission errors on recordings, but now working perfectly. Very happy camper!


Hi Roger,

I stopped using my Slice a while ago after it developed a persistent problem when it scraped TV content it would unmount the 2Tb disk I got with the original launch.

It was okay prior to openelec with the old software - but since I updated its kept dropping the disk.

Do you know if this is a known issue, or something my Slice is suffering on its own?

I’ve just gone thru the various instructions to update to this release (CM1 version) and its installed fine - but then started to unmount the disk as soon as I tried using Kodi in anger,

Many thanks



I recall, a long, long time ago…there were issues with the Slice and unmounting also seem to recall that there were some issues with disk formating on some units. If you search this forum on those topics you may find the condition you have described.

Have you ever reformatted your drive?

I had issues with mine, and sometimes the disk does not power up after going into standby, so the system cannot see the media files. a power off (physical) raher than reboot, i.e. remove the power plug, resolves the issue and the media files are still there :slight_smile:
Hope this helps,




Yes - I bought one of the early bird 2Tb units when the kickstarter launched back in the day. The drive wasn’t formatted correctly then, so I followed the Ninja guidance at the time and reformatted it.

Having read all the forums, I’ve done rollbacks and reinstalls but its never returned to a stable state.

I suspected the Kodi Ad-ons for a while - as the unmounting of the disk occurs after the TV Scraper is used - strangely the Movie Scraper works ok - but even disabling and using a different scraper hasn’t helped. The Kodi player now only sees approximately 12 folders in the TV folder - rather than the 50 that are there. I’ve tried rebuilding the database - I exported a copy of the database and it has the full structure (inc missing folders). Not sure if thats down to some files permission issue thats changed between updates (System not being allowed access to files?)

The unmounting now appears to occur a bit more frequently (but I stopped using Slice for a while in frustration).

Is there anyway to do a total fresh install? I couldnt gain access to the mounted eMCC using the tool yesterday - despite a full drive repair - so had to resort to dropping the Tar in the update folder from file explorer.



the emmc drive does not always show up, try re-instering the USB cable in another port. Also you have to put the USB cable in BEFORE inserting the power plug in the Slice this link refers The Slice wiki has more info if you have not seen it.

Does any of that help.

I have done mine a few times while testing software for the Five Ninjas.

The other thing I noticed was erratic behaviour database wise and an inclination to “just reboot” on the CM1. It went when I upgraded both my devices to CM3. I guess the CM1 was not really up to all the nice fratures in LibreELEC



Hi Roger,

I’ve managed to mount the eMMC - schoolboy error of forgetting the power - its seen one partion of 120Mlb called RECOVERY and looks to have the Noobs files in it. (drive E)

Its then got 2 separate USB mounts that were unformatted - I’ve quick formatted FAT32 and got 528Mb and 2.99Gb - I’m currently trying to read all the articles to understand how the eMMC should be configured and installed. I was getting lots of issues on updates previously for OS being unstable/unsupported or running out of space in the partition on Noobs- so guessing some resizing may be needed.

A bit of a learning curve - what I’d like to have configured is a dual boot option so I can have OpenVPN installed to access my files when away from home and use it as a low power NAS… but baby steps.

Its annoying if I need a new compute module - are there any benefits? I have noticed SLICE didn’t like larger media files and the framerate would considerably drop on anything above 1Gb / 720 - is that improved with the new board? It starts to look easier to but a cheap Kodi box for £30 than bother with the CM3 upgrade?



So - I’ve managed to get back to a clean 8.2.0 build and rebuilt the databases from scratch - it is still ignoring the same folders in the TV section.

I’ve used FileBot to rename all 1,700 files to the format the TV Scraper is expecting to see - but it’s still failing to recognise these files. There were a few illegal characters in some files - which I found and got rid of - which may of thrown the scraper.

I’ve used WINScp to log on to the box and check the permissions of each of the folders in the filestructure and they appear to have the same system level access permissions on both the files that work and fail.

I’ve run the scraper again and its still dismounting the disk on the TV folders. Is there a max depth file structure limit, or max total path length limit that is being breached (like nesting seasons separate folders?)

I really invested in the Slice kickstarter for the polished product - that was hackable to play with Pi and restore as a media centre - but I’m doing more hacking trying to get it to work!


Have a look at this old thread see if it helps…

basically, make sure you safely eject the hard drive if connected to a PC, properly shutdown the slice if powering off,
also try re-seating the hard drive just to make sure there’s not a physical connection problem.


Thanks - done all of those already


after renaming the files - Kodi is seeing less of them - could this be an issue with windows modifying permissions? Still detaching on scan - reboot and drive is back



You could try VPN on the Slice, here is a link to such a solution, “others are available” :slight_smile:

I have not tried it but I use openVPN on my Pi3 to access the internet from public places on my mobile devices. It works well. I can use that to access my Slice too. Streaming from your Slice, the success will depend on your ISP uplink speed, especially for video (lots more data being sent).

The CM3 is a worthwhile upgrade but you will need a heatsink to couple the CPU to the Slice case, heatsink examples here and mine is here. That makes it into a cool running and capable slice. I have two and I am happy with them, the CM3 upgrade made a huge difference.

I guess it is a question of how much you love your Slice v cost of upgrade v cost of alternative. KIV ISP uplink speed though for streaming video.

Hope that helps,