Multiple issues with new Slice


Two major problems with my new Slice - purchased only to play random mp3s and run random slideshow.

1: No audio output on 3.5mm jack - [makes no difference if set to jack only or HDMI & jack] - Audio is fine on HDMI. I get a slight crackle as I plug a jack in so it is connected internally.

I need audio from the 3.5mm jack as my current monitor has no aux audio output [unless someone can suggest a breakout from HDMI to 3.5mm jack?].

2: Slide show locks up - I have a personal photo library of 25,000 pictures - when I attempt to run a Recursive Slideshow the system freezes. ssh not possible, recycle power.

Last message before lock-up [ tail -f /storage/.kodi/temp/kodi.log ] is:
10:22:08 T:1968943104 ERROR: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop
10:22:08 T:1838122048 ERROR: Led Pattern 2 triggered
10:22:20 T:1802359872 NOTICE: Thread JobWorker start, auto delete: true
10:22:43 T:1968943104 ERROR: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnClear
10:22:43 T:1968943104 ERROR: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnAdd
10:22:45 T:1821344832 ERROR: Previous line repeats 1129 times.
10:22:45 T:1821344832 NOTICE: Thread JobWorker start, auto delete: true
10:22:45 T:1968943104 ERROR: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnAdd
10:24:03 T:1948251200 ERROR: Previous line repeats 20350 times.
10:24:25 T:1948251200 NOTICE: CAESinkPi:AddPackets Underrun (delay:0.00 frames:2205)

then system freezes and ssh unresponsive.

version & df FYI

Slice (unofficial) Version: devel-20150327072056-r20080-ga7e4b46

Filesystem 1K-blocks Used Available Use% Mounted on
devtmpfs 169120 0 169120 0% /dev
/dev/mmcblk0p5 163660 154960 8700 95% /flash
/dev/mmcblk0p3 3030800 61248 2953168 2% /storage
/dev/loop0 144768 144768 0 100% /
tmpfs 174272 0 174272 0% /dev/shm
tmpfs 174272 6796 167476 4% /run
tmpfs 174272 0 174272 0% /sys/fs/cgroup
tmpfs 174272 4 174268 0% /tmp
tmpfs 174272 20 174252 0% /var
/dev/mmcblk0p1 122596 30096 92500 25% /var/media/RECOVERY
/dev/sda1 976760832 229002496 747758336 23% /var/media/Slice-HD

Slice1:/var/media/Slice-HD/pictures # find * -type f | wc -l

I’m willing to firkle with the system in order to resolve these problem but I must have audio via the jack.
If this is not possible, please confirm return procedure for faulty products.



If anyone from Slice is interested (which I’m kinda sensing they aren’t), I’ve identified at least one jpg that causes the Slice to completely crash when running the slide show.

I can provide the jpg for someone to debug this further. (These images run on an iMac slideshow and other platforms without crashing)

11:09:58 T:1774003264 NOTICE: DecodeJpegToTexture: unable to decode to texture /media/Slice-HD/pictures/thursday/1783.jpg 1080x1620
11:10:19 T:1774003264 NOTICE: DecodeJpegToTexture: unable to decode to texture /media/Slice-HD/pictures/thursday/3138.jpg 863x1080
11:12:42 T:1774003264 NOTICE: LoadJpeg: unable to load /media/Slice-HD/pictures/thursday/800.jpg
11:19:18 T:1774003264 NOTICE: LoadJpeg: unable to load /media/Slice-HD/pictures/thursday/196.jpg
11:24:47 T:1774003264 NOTICE: LoadJpeg: unable to load /media/Slice-HD/pictures/thursday/2171.jpg
11:25:24 T:1774003264 NOTICE: DecodeJpegToTexture: unable to decode to texture /media/Slice-HD/pictures/thursday/255.jpg 1620x1080
(final message in the log before the Slice dies)

Rather amusingly, the photo is the control panel of an early A-bomb :slight_smile:


It’s more likely that the problem is running out of memory. Kodi doesn’t do music or pictures very well, I’ve got a pretty large cache of photos, but never try to browse through them because of problems like this.

Originally we were going to remove the photos option from the Skin for this reason but decided against it.

As a suggestion, one nice way of using photos is to load up the photo screensaver addon from the standard repository. Then whenever the box goes into standby it treats you to a random play of your photos.



Hi Jerry,
Analogue sound should work fine, I use it all the time, you need to go to System Settings -> Audio -> Audio out
and set it to ALSA: Default (snd_slice Analog) or if yours doesn’t say this try each in turn.
As Gordon says, entering a directory with thousands of photos in causes Kodi to cache a whole load of meta data, which on a lowely computer like the pi rapidly locks it up. Try only putting a few hundered photos in each directory and see how you get on. I seem to remember that a recursive slide show will also cache loads of meta data, so try avoiding that as well, it’s really a Kodi problem not the fault of the Slice. :frowning:
Regards, Kevin.


Thanks for both your replies and apologies for my delay in responding while I worked out a response.

Setting the audio to ALSA enables audio output on the 3.5mm jack. Incredulous that that’s not automatically set when analog output is chosen from the menu.

Further to the slideshow crashing the Slice, from experiments I’ve since made, it seems that there is a similar issue when attempting to play a large number of mp3s, randomly or otherwise. That crashes the system too. :frowning:

Even if these are Kodi issues, if the Slice is only able to run a slideshow of a few hundred pictures, without crashing, and has similar limitations when playing audio files, then this surely this should be clearly stated in your marketing material?

Initially I also struggled getting the unit out of mute. If the Power Menu mute option showed bright red, as does the ‘mute’ bar at the bottom of the screen, the solution would have been immediately obvious.

Reasonable documentation would have quickly clarified all of the above issues, without having to post questions on forums. This does not make does not make the Slice solution scalable.

I’ll keep the unit and build a custom solution. Looks like this Perl hacker of 25 years is about to learn Python!

Although, as I don’t even need a menu system, just an mp3 player with a slideshow [from power-on], do you think I would be better off scrubbing and installing Raspbian? That would also save me learning another language. If that worked I would probably buy a few more Slices. :slight_smile:

I applaud your efforts and wish you the best of luck - I shall be lurking and hunting out lots of tech. info.



Hi Jerry,
I have used Raspbian on Slice, works fine.
Be aware that (I believe) Raspbian will not be able to use the analogue audio out, as on Slice it uses a high quality DAC design, different from a Raspberry Pi. @Gordon should be able to confirm or otherwise. You could possibly extract the sound from the HDMI output if it came to that.
There is a very exhaustive Slice wiki, with all sorts of useful information on it, you’ll find a link to it somewhere in these FiveNinjas forum pages, almost certainly pined. Found it:- Slice Wiki.
Good luck. Kevin.


Cheers Kev

I think I’ve found a way to breakout the audio from HDMI, so that should be ok if I took that route.

Yes, I’ve already found the Slice wiki thanks.

Playing with the leds now - love the .png idea.

Quick Q then I’ll leave you alone.
Is there anywhere that shows which kodi-send actions are active on Slice. Lots of actions seen on the Kodi built-in-functs page don’t seem to exist on Slice “no such action ‘playmedia’ defined”, etc.



I would suggest you have a look at the sources to find the built in’s I’d guess that the wiki is ‘out of date’

Make sure you know which version of kodi you are running and use the data for that. If you’ve updated your box to LibreELEC then you’ll be much closer to the sources


Hi Gordon

Thanks for the info. Lots to do now.

If there’s anything else, I’ll take it to a new thread and let this one drop away.




I have had the same issue with playlists on MP3, I reported it here playlist problem post #59 as I am using chewitt’s build which is quite likely to become the newer long term version for Slice.

Enjoy the Slice.

@chewitt : someone else with MP3 issues FYI