New Stable / Nightly / Bloody build [Oct 19 2015]


As of this morning there is a new release to upgrade to…

This includes the following changes:

Latest OpenELEC-6.0 release (stable for quite some time now!) including latest Kodi 15.2 Isengard
Overclock settings fixed
Hard drive standby and sleeping
LED startup sequence only played once
RTC fixed to stop losing an hour on reboot
Change “TV shows” to “TV Shows” (Thanks pedants of the world)
Add standard OpenELEC update mechanism
Disable PWM audio to stop breaking the LED control
Update LED patterns slightly
Completely open source release update

For those of you running bloody just go into the OpenELEC settings -> check for update otherwise reboot to the recovery menu to update to Stable





Worked for me too! I am on Isengard now!!

Nice led startup sequence by the way!

Little bug : thr tv shows correction was also applied to the German language. It was TV Serien before which would be right.


What a difference so much faster ! Like isengard and the menu changes. Great job Gordon. Thank you sooo much for your help :slight_smile:


Great update - sooooo much quicker up and down the menus!!

Slight issue - the slice is still losing an hour at each reboot…

Hope that helps?
Thank you for the excellent work involved in this update


The clock seems to have reset itself to the correct time.

Thanks again!


Actually you’ll probably find this happens again, to fix it you need to get the latest files from the installation, which means resetting your Slice…

This means you’ll lose your library (not the actual files but the library containing the downloaded tv/movie information), but also means you’ll get the hard drive sleeping and shutdown code implemented correctly

Go to Setup -> OpenELEC Settings -> System -> Reset System Settings to defaults

This should get you the clock working properly again



I have installed the new stable also - apart from the clock bug still being there, the only thing I would point out is that you absolutely MUST backup your databases!

I stoopidly did not and had to re-scrape a few dozen entries. When the new stable is loaded @Gordon, where does Slice get its database info from??


downloaded and installed bloody, works fine.

Thank you for all the hard work.



Read the previous email, this applies to anyone who’s coming from an old stable or nightly build… The clock bug will be fixed with the reset



I guess even more reason to back everything up before the reset.

@Gordon, should the reset be done before or after the new stable build is installed??


Do the reset after the update


Yes as Mike says, afterwards…

The installation system does not overwrite the setup files (things like the startup script and shutdown script) because people like to keep their settings between updates, but of course when you’ve a change that only effects those files (adding the shutdown script or removing the hwclock call from the startup script) then you need to be able to overwrite them all and throw away all the settings…

In future I may implement some of these changes in the upgrade script instead so the upgrade won’t need it but for now the reset is the only way to get there!



I’m trying to update. But it doesnt find one. I tried updating in settings-openelec settings-system-check for update now. Is this the right place?


In the recovery menu I can only choose nightly and WTF. No stable.


The openELEC settings check update is not enabled in the version you have, you’ll need to update first…

Go to the recovery system, click fast forward to first update the recovery system (NOOBS) and then you should get the new stable option



After the update kodi did not see the internal HD.
It was only after rebooting it was avalible again.
But this happens every few reboots that there is no sign of the internal HD.
Had to reboot 2x the last time to get the HD to show.
Never had this on any of the previous builds.

Connecting the slice to a PC works every time so its not a HD or hardware issue.

Any idea whats causing this ?


Would be useful to get the log out of the box when it doesn’t work…

Do you have ssh access to the box (or putty on Windows)?



Thanks, this fixed it.


@Gordon the hard drive stand by and sleep…does this just happen when the device hasn’t been used. Or are there options to select to put into these modes?