New Stable / Nightly / Bloody build [Oct 19 2015]


That’s what has been implemented. I was looking for what’s upcoming (I forgot that word in my post :smile:)



Still getting the problem with the slice powering off.

I have checked the Ethernet light as you suggested and the light has in fact gone off when the “shutdown” occurs.

I have an onkyo amp and a Panasonic plasma tv.

I have checked the amp and CEC is switched Off, I have checked the TV and Viera link is switched off.

I have eliminated the amp as the problem by connecting the slice directly to the TV (with a different hdmi cable and to a different hdmi port on the TV), Every time I switch off the TV about 5 seconds later the Ethernet light goes out and the slice switches off. I have to pull the power and plug it back in.

I have tried switching off the slice’s screen saver, I have gone into the slice’s XMBC Setting, system, input devices and peripherals option and switched off all the options, but still getting the problem.

Everything has been working great since I got the slice a few months ago, only started having this problem after installing the latest slice stable version on Saturday.

If you cannot provide me with an solution, can you please tell me how to go back to the software that the slice came with. As it is, I cannot use the slice as having to reboot it each time I switch off the TV is not good.

Thanks in advance.




OK, if you have ssh connection to the Slice then, one thing you can try is to wait until it happens, then reboot the box and ssh into it then type:

# paste .kodi/temp/kodi.old.log

This will give you a link can you post that here?





Thanks for the reply.

I have no idea how to use SSH




OK, will see about adding that functionality to the build… But I’m fairly sure the problem is still the TV telling the Slice to power off over CEC…




You may well be right, but like I said, it was not doing this until I put on the latest stable release. So something has been changed, in Kodi, Openelec etc. At the minute the slice is fairly useless.

Again, as I asked the other day, can you please tell me how to revert back to the software that came with my slice so I can start using it again.





Follow up,

I have been trying a few things and I can confirm that my Panasonic tv remote is controlling the slice, I have viera link switched off on the TV, so it should not be doing it, and was not before the update.




It’s likely that someone has changed the default mapping of CEC commands to slice commands and added a power down command…

What I’m adding at the moment is something that will enable you to upload your debug files to pastebin so that I can view the debug log… Then we should be able to find the resulting problem file…

We currently don’t have the ability to revert back to any previous release which is why I can’t help with that right now, sorry…





If you now update to nightly you will get a new option in the OpenELEC settings

Setup -> OpenELEC settings -> system -> Paste debug to pastebin

If you click this and wait it’ll output a web link, if you post that here I can see your debug log (if you post it after the shutdown happens we should be able to see the log from the previous run)

You’ll probably need to enable debugging as well

Setup -> XBMC settings -> System -> Debugging




The link shows as

Thanks for your help.

So you know, my Panasonic TV remote directional arrows and ok and power toggle all seem to work on the slice. Obviously the power on/off being the main problem for me.




Ok, so I followed Gordon’s instructions (above) and got the following:

I have devel-20150327072056-r20080-ga7e4b46.

When I do the reset, I get the Slice (stable) tab and when I choose the install option I get “Warning: Incompatible Operating System(s) detected. The following OSes aren’t supported on this revision of Raspberry Pi and may fail to boot or function correctly”

I pressed on :slight_smile: and got:

“Error downloading or extracting tarball
1970-01-01 00:00:34 ERROR 404: Not Found. tar: short read”

I think I need help :-))


I think it may be a problem with installer files… If you do this it will lose your library settings such as what media is where…

If you have a USB keyboard, plug that in:

login with username ‘root’ password 'raspberry’
type ‘noobs_update’

When it finishes, give it to a count of ten then unplug and plug in again…

Should then work


Thanks! I got there a slightly different way, as when CTRL-ALT-F2 was pressed from boot, I got text appearing at the login prompt that rapidly vanished and the machine was blank.

Instead I used it after pressing the Ninja button and that worked fine.



Gordon - when I try to update the NOOBS software as you suggest earlier, I get stuck with a radioactive warning screen telling me that is it “Testing md5 sumi (Safe to power off / reboot)” and the systems hangs there. If I do reboot, there are no updates. Suggestions ?


Can you do it the other way, go into the recovery system, press Ctrl-Alt-F2 and log in username “root” password “raspberry” then type noobs_update

When it’s finished then reboot your slice…



@Gordon I am currently on devel-20151114133823-rt1617-g3f26412 and when I check for update there is "Latest version g37b2ebb"available for download. If I choose to update to this new, it is downloaded 20151120211245-r21619-g37b2ebb.tar, then extracted (extract file SYSTEM and Kernel), then auto rebooted. On the this next boot I see following log:
Checking KERNEL.md5…
/storage/.update/KERNEL: OK
Checking SYSTEM.md5…
/storage/.update/SYSTEM: OK
Checking size: FAILED
size check failed. normal startup in 30s…

and after this 30 seconds it boots to previous version, with notification that there is update available. I tried this 2 times already, results are the same.

Any advice would be helpful.
Thanks in advance,


This is because you are trying to install a bloody build which is currently a bit broken… Please switch to nightly

The bloody build is only for use if I specifically ask someone to try it because I’m trying to get them to test something I can’t do here. It is also the build I use for continuous integration and testing of builds so will occasionally be broken.



ah ok… I am actually pretty satisfied with this build, feels snappier than ever… Hopefully nightly already got that code and my library will not be lost during change. Thanks


Hi Gordon,

I wanted to upgrade my KODI to 15.2 Isegard Stable. After I click on Check for Update Now, nothing happen. Kindly advice what I need to do to upgrade KODI safely. (Ie Installed Add-On & Repo remained?).

Thank you and hope to hear from you soon.

Sam NZ