Not enough disk space when updating


When trying to install the new stable build i keep getting the message shown in the attached pic.
“Not enough disk space…”

Anyone any ideas?



That is strange,

I wonder if the problem is that your storage directory is full…

Maybe press Ctrl-Alt-F2 and log in as user “root” password “raspberry”

Then do


And see what it says




Sorry its tokens long to get back, but this issue is still happening. Seems I can update at all.

Im guessing you would require a bluetooth keyboard to do this?

Is it possible to reset the software and start again?


A wired usb keyboard will plug straight in.


I’ll try that cheers.



Got the info below when logged in as user.
Thanks for the suggestions Keith.



I’ve also noticed I always get the notification stating Updates are available, even after i update set to auto or update manually.


Get this each time i start as well, if that helps in anyway.


Glad the keyboard worked!

This looks suspiciously like an issue I had a while back.
The update didn’t run because it kept failing the checksum.

Here is the link to the fix that worked for me and Gordon’s explanation.

I may of course be COMPLETELY wrong :smile:
Someone “qualified” will be along soon I’m sure…



Also when you’ve got to the recovery console can you do

ls -l .update

And see what is there?



Thanks I’ll try that.

Also when logged in as user how do I quit? Not 100% with keyboard commands.


You’re fine just powering it off since there’s no writing to the flash at that time…


Got this msg, wasn’t sure if it was an I or lower case L you had there so tried both.
Still not sure whether i did it correctly or not, tried it in the noobs screen but that just lets you check the language.



You need the spaces

ls -l .update


Got this after inputting the spaces.



Can you try typing:

$ parted /dev/mmcblk0

This will start the partition editor on the drive, next type ‘p’ and enter to print the table, then type ‘unit s’ and press enter then ‘p’ and enter to print it out again but in sectors (just helps with calculations a bit!)




Hopefully this is what you’re looking for, didn’t work the 1st time but then tried without the dollar sign at the start.



That’s strange, it’s completely different to mine…

From the command line can you type:


This should download and extract the noobs files again… then


Finally power off the Slice and power it back on again

Should come up with the selection menu, don’t install anything just ctrl-alt-f2 again and repeat the parted /dev/mmcblk0 and take a picture

Next Ctrl-Alt-F1 to get back to the menu and select Slice (stable) and “Install” (ignoring the warning messages)

If that doesn’t work can you return to the command line and repeat the parted commands again…




Performed the update and sync and got this.

Tried the install and got this

Then got this when i went back in the parted bit.

Now overtime i try to login I go to the Recovery bit, which i hope you get.
Then when the install doesn’t work again I can get a blank screen with a red square at the top,which I’m hoping you were expecting. :slight_smile: