Occasional double-key issues with remote control


I think I’m getting occasional double-key or key-bounce issues. Particularly noticeable when navigating down lists of media, one time in 4 or 5 one press of the [down] arrow will move the cursor two items down. Also, [ok] will sometimes be repeated when pressed when on a directory, with the effect of entering the directory, then immediately backing-out again (the first entry in the directory lists is usually “…” to go back up.)

Is there any de-bounce timing I can try tweaking, or a relevant log of key presses?



It’s a surprise you’re getting with, is this with the supplied remote + WiFi plugged in or do you have other things plugged into the USB?



I get the same issue with the “down” button on one of my remotes too, the other one is fine. Haven’t noticed a problem with the OK button.

I have it plugged in to the recommended slot, with the WiFi in one of the others, same configuration for both remotes.


Your message reminded me that I did have a USB keyboard plugged in to Slice as well as the Slice rc receiver. (No wifi … my Slice is networked via RJ45, and nothing else connected by usb). I’ve just unplugged the usb keyboard and repeated some rough tests. I still get occasional double-presses and - sometimes - missed presses where the remote button makes a tactile click, but no response on screen. It’s too bright in the lounge to monitor the tiny blue led on the the remote control as well as the screen…I’ll try again when it’s darker.

By the way, the usb keyboard was necessary to trigger an update to the nightly builds a couple of weeks ago … are there any plans to make that functionality (the tab key to install) available via the Slice remote?



The slice remote’s top left button is the tab key which you should use to exit the NOOBS dialog and install the OS.

The top right button (context menu, three lines) is used to enter the NOOBS screen and exit without installing



Thanks for the top-left == tab note, Gordon.

With the usb keyboard disconnected, so that the Slice remote is the only thing connected by usb, I’m still getting occasional missed and double-key entries, most noticeably when navigating lists.

I’m mostly using the Confluence skin, so I wonder if it could be related to a performance issue?
(I’m using Confluence at the moment rather than the Slice skin since I’m more used to managing media, scraping art and info etc with Confluence.)



If you could try the Slice skin, and see if there’s any difference, that’d be interesting to know. Confluence performance shouldn’t be bad, as OpenElec/Kodi on the hardware was performing pretty well even before we finessed things.

If it does get rid of the issue that should be a big indication that Confluence is hogging the CPU too much :slight_smile:


I’m experiencing similar issues. its fairly infrequent but is noticeable.



I’m experiencing the same issue with the down key. Not so much with the okay button. Using another skin does not fix the issue. The issue occurs on both my Intel NUC with a Celeron and on my MacBook Pro with an i7. I don’t think the confluence skin is to heavy for those machines. What I did find though is that when there’s more distance from the receiver it’s occurring more frequently. It also started getting worse from the couch so my wild guess is it has something to do with the battery and reception of the signal.

I will see if replacing the battery fixes the problem but I currently do not have any of these batteries lying around.


I’m also getting this issue, but with all buttons.
Sometimes if I try to get into a Series it clicks again and I’m back where I started.
Or I try to go back a folder and it “helps” me get back to home screen.
It’s really annoying.

Hopefully someone got a way to solve this


Sporadic booting issues (no video output) and garbled audio [RESOLVED]

+1 for remote button double-clicks on (at least) nav buttons and OK. Battery replaced; issue still exists. Emerged after upgrading to 27-03-2015 nightly build. Still there with latest(?) nightly build (19-05-2015). I have only the remote dongle connected to the Slice (using Ethernet for networking)


I recently upgraded to the most recent Bloody [31st Oct 2015]build and the double click disappeared.


For me the problem persist since the 1st day of Slice. I tried so far also the other builds: Stable , Nightly, Bloody. Then I moved the remote receiver to other USB ports, and also disconnected the Ethernet and the external USB disk. Also tried with new battery but still issues persist.

As far as I understood the double / triple multiple click is happening even when pressing the keys very shortly. it happens when there is a transition on the screen [like a a new screen entering / exit a sub menu or loading a new thumbnail for a movie].

Is there a way to regulate the key repetition delay or something like that ?


I’m still seeing this with the 20151114 Slice build.

FWIW, I now believe it’s the remote rather than the Slice (but I’m prepared to be convinced otherwise). It’s easy, for instance, to push a button too gently and not register a press, but the double-tap occurs more often. I’m wondering if it’s a contacts thing. Anyone tried any alternative remotes?


You could try setting up an alternative IR remote… Unfortunately this is not as easy as it sounds because if requires you do it through SSH…

But if you want to have a go search for “openelec lirc” on google and you’ll find some instructions


I connected the USB remote to a linux PC and noted the same problem of duplicated keys.

I tried both on KODI and also on a simple text editor with cursor scrolling.

So in my case the problem is with the remote control itself and not with Slice.


There are great instructions for setting up a different IR remote in the Slice Wiki:


although I am having a little problem with programming the Ninja and TAB keys1!

Apart from those two keys, all the others work fine, and I can navigate the Slice without any double key presses or missed keys :smile:

The reason I’ve been trying to get a different remote working is because I too have had endless problems with key bounce on the supplied remote. I’ve only got the remote receiver plugged in to USB on the Slice. Double-presses and missed presses have always been a problem for me, and it seems to be getting worse with time, which I put down to the supplied remote wearing out…

BTW I’m on the current stable build, dated 20/11/2015.


Cheers, @shutterbug - I will give that a go. I have an old Apple remote kicking around somewhere, so I’ll dig it out and try it.


It’s the remote.
I bought one for my HTPC (OpenElec/Kodi).
I’m getting a lot of unregistered presses (pressing too softly, mostly with the OK button). But the most annoying thing with this remote is the double presses. It’s so common that I’ve almost thrown it in the trash. Totally unusable for typing anything. Extremely annoying navigating the menus.


The thing that surprises me is that some remotes are working completely fine otherwise everyone will complain about it. Don’t know if I am getting sensitive about the issue but it seems that my remote is getting worse and worse every day.