Raspberry Pi Compute Module 3 has been released


Thanks for the instructions!


After rebooting everything twice I now seem to be getting somewhere!

The key was rebooting the Slice while it was connected to the laptop USB, despite instructions to do it the other way round. This seemed to force the detection again.

Watch this space, I’ll let you know how I get on.

Cheers - Roy


I had this issue as well, I solved it like this:

Unplug power and usb from Slice
Start rpiboot.exe on Windows machine
Plug usb into slice
Plug power into slice

RPIBoot now spotted the slice drive.


Glad to help, let us know how you get on.
Good luck



will let you know once i receive the CM3 and find a working Windows machine :smile:

Have you tested the CM3 much with Slice. Does it really need extra “cooling” like a heatsink or something


I have a Slice and a Slice Lite. I use the Slice Lite (here) for testing so the CPU is on the top. It certainly gets hot and I consider it really needs a heatsink as inside the Slice the heat will strugge to find a way out.

Gordon has used a few thin copper sheets to make a bridge between the CPU and the Slice case as reported elsewhere on this site. Reports it helps a lot.

I think that the sensible solution is to move the heat into the case as there is a lot of metal there, ideal to act as a sink

I have asked Gordon if there are plans to sell more Slice and if so, with the CM3. In that case they may consider making a heat sink and letting the “early adopters”, who have upgraded, purchase one.

Watch this space! In the meanwhile I will see if I can fashon a bridge between the CPU and case from a lump of copper recycled from an old PC CPU sink. Copper is far far better than aluminium for moving the heat away across the bridge.



Looks like my CM3 is dead, boot with just power i get the rainbow splash screen
With just the USB connected to host i can see the HDD
With power and usb connected to host, running rpiboot returns "Waiting for BCM283x …"
The thing is if i remove the CM3 and replace it with the CM3L rpiboot see it fine, also with the CM1 it works fine, so for some reason its just the CM3 that’s not working @Gordon any ideas?


I had that Issue Mike, looks like the image you installed has an issue, I recovered it by following these steps:

Unplug power and usb from Slice
Start rpiboot.exe on Windows machine
Plug usb into slice
Plug power into slice

RPIBoot now spotted the slice drive



That does not work, but only for the CM3, all my others work fine, so i know the process is correct


got my CM3 and put it in my Slice.

INstalled the drivers etc from CM-installer package to my windows 10 machine. When i run the rpiboot.exe it finds the device and writes something but then goes back to the “Waiting for BCM283x”


Try repowering the Slice


I think i got the rpiboot to go through. I saw lot of text. But Windows doesnt show the 4gig drive after the rpiboot window has automatically closed.

So not sure if the flash has succeeded with rpiboot or not


After being out most of the day, I’m back on the case!

I’ve managed everything in Gordon’s instructions, rpiboot to prepare the eemc, then using the SD Installer to copy the image over. All copied fine.

When I power the Slice with just HDMI plugged in, it just boots to the rainbow splash screen and sits there.

I’ve been through the whole process twice now with exactly the same result. What am I doing wrong?

Thanks - Roy


did you flash the right image?


That’s a good question :slight_smile:

I followed the link that Gordon provided above in his instructions, and the file I’ve used is called:


I’ve also just read that corrupted flash can cause a hang at the rainbow splash, so I’ve just used SD Formatter to wipe the eemc, then gone through the process again, but unfortunately with the same result - hanging at rainbow splash.

Thanks - Roy.


Hi, sorry I’ve been out rowing and only just got back to the computer!

@shutterbug Are you sure that you are writing the image to the eMMC (it will be 4G) and not the hard drive? Otherwise, maybe instead try using win32diskimager to copy the image to the 4G filesystem rather than using the LibreELEC writer…

@MikeBuzz The CM3L does not come with the OTP programmed sufficiently to boot the Slice from the hard drive. I’ve now got it booting on my desk, but require special software to achieve that.

@shutterbug Sometimes I find the somewhat strange use of the USB for Slice breaks the windows driver system so it can require you to reboot the PC if things go wrong.

NOTE: plug in DC jack, then uUSB this will give you access to the eMMC (using rpiboot)
Plug in uUSB only, this is give you access to the internal hard drive

Selling Slice 3 / pre-programmed CM3 / CM3L

It’s not really up to me whether this happens because I’m not the one on the hook for the work to make the devices and sell them. This is actually done by Pimeroni, currently they are thinking of stopping production of Slice devices because it’s not really making them any money (we’re only selling the odd one a week!). Overall Slice has been a relatively large loss for everyone involved :frowning:

I’ve been trying really hard to work with and support the LibreELEC guys because they have been trying to get Slice supported as an official build (it is after all an awesome piece of hardware made even better by CM3). So hopefully the path to builds / updates is open as we go forward




Hi Gordon,

I hope you enjoyed your rowing :slight_smile:

I went around again, but this time as you suggested loaded the image using win32diskimager, and now it is fine. Thanks for your help as always.

I’m really saddened to hear that Slice hasn’t been a successful venture for The Ninjas.

Regards - Roy


a noob question that everyone is afraid to ask :blush:. Would it be possible to migrate the existing configuration in SLICE to the the CM3? All the plugin/settings and so on ?


There is a Kodi add on called Backup which allows you to export your settings and library, then import them to a new device.

I’ve not tried it, at the moment I’m just pleased to have a working device :joy:


Still cant get the eMMC to show up on Windows. I think the rpiboot finishes successfully as I can see it doing something (as the lines scroll very quickly) and then it closes automatically but Windows just doesn’t show the new partition.

Might need to test on another laptop today/weekend