Raspberry Pi Compute Module 3 has been released


Asus is also hopping on the Raspberry train with their own board


It was a bit of work, but I got my Slice to work with the CM3 (from RS within 2days supplied by DHL). RPIboot initially did not recognize the eMMC. Tried another computer and also not. I started on a USB2 port then switched to USB3 but still RPIboot did not find the BCM283x. Then I unplugged/plugged the power and suddenly RPIboot started to work. Then used the USB installer as Gordon suggests with first Libreelec and then Chewitts build. Works like a charm, I am currently setting it up and I also need to fill the 2TB disk again as I formatted it while trying to make the install to work. Anyway all seems good and I finally will be using my Slice again as the speed is so much better. Looking back at having done this, I can advise everyone to do the CM3 upgrade.


Ok thanks @Gordon, I’ll get the standard version, as it sounds like it may be a while before you’ll get a chance to make the lite bootable. Presumably, if it happens, the standard version could boot from USB, just like the lite, the on board eprom would then become redundant.
Regards Kevin.


done mine without too much trouble

but I had to manually load the drivers twice before the drive would appear.

you know goto device manager and update drivers then press browse my computer then press pick my drivers from a list, click have disk and browse to said drivers.

I hope that helps some one out there.


Finally got a CM3. Cobbled together a playlist of instructions from all the comments here, but still had issues not addressed by others as well as some issues that have already been mentioned.

In summary: Replaced old CM with CM3. No issues, except I noted rubber feet have moved somewhat since new.
Downloaded CM-Boot-Installer and installed. Downloaded LibreELEC installer and Chewitt Slice3 ,img.gz file from Gordon’s links (thanks).
Connected Slice to Windows 7 desktop through USB hub and provided power to it. Got the XBox controller device installed. Deleted driver and reran RPiBoot installer to reinstall driver. Tried to manually change driver. Gave up and ignored XBox driver, assuming it to be some clerical thing, and focus on RPiBoot.
At this point it got messy and blurred. First off RPiBoot wouldn’t work. Unable to establish a connection or something. Tried power and USB connection unplug/plug to no avail. Eventually (based on a comment somewhere above) I rebooted the PC. I also bypassed the USB hub and connected directly to PC. So now RPiBoot did something, not sure what, because it was on the screen about 3 milliseconds. Nothing new showed up diskwise. Eventually, after several reboots, Slice power cycles and cable unplug/plugs and rerunning RPiBoot, it seemed to have done what it was supposed to, except I still couldn’t see a 4Gb disk. At this point, Windows told me a disk needed formatting. No-one mentioned formatting. What to do? Disk manager showed it was in fact a 4Gb disk, so sure, go ahead Windows, format my disk…
I changed the drive identifier to S: to make sure I wasn’t screwing with anything previous. So now I have my 4Gb disk showing up with a name that includes RPi so I assume (correctly as it happens) that I’m over that hurdle.

LibreELEC installer was a little funky to use - basically ignore Step 1, select the Slice3 .img.gz file in step 2, select drive S: in step 3 and hit Write. Couple of minutes and boom, written.

Eject USB drive S: from PC, power off, disconnect USB, hook up to monitor and hey presto, we have LibreELEC (Beta) running. Contents of 2Tb drive still there, so good. Into (Expert) settings, all familiar territory, and set region, time server etc. Temps running at 142F (61C).

All good until I point Files at my NAS folder for movies (over 1000, with another 300 DVDs yet to rip). Starts indexing and suddenly I have this interesting little thermometer icon in the top right of the screen, showing half full. Check temps again, now running at 180F plus (80C plus) and the icon goes to full red. So quick shutdown and power off.
Haven’t turned it back on yet, as I am now following the heatsink debate before deciding how to progress…

Thanks for all those that have gone before, and your comments. Not sure I’d have got this far without them! But it’s looking good, and very, very, fast.

Yes, I would recommend this upgrade to my friends :stuck_out_tongue_winking_eye:


I think Asus are more like hoping on the Pi train (and community)


Ian, I wouldn’t worry too much about the thermometer - the CM3 throttles back the CPU as the temperature rises to around 85 degrees so as to prevent any damage.

Hopefully @Gordon can confirm this!



Rasppishop is now listing the CM3 for german customers. But still unavailable. Opted in for a notification.


Mine frequently shows the thermo half filled and sometimes fully filled. The max. temp I saw is 83 degr. All seems to keep working fine, no throttling noticed yet ( just music so far) . I hope someone will come up with a good cooling solution incl. pictures. I read the operating temp should preferably stay below 75 degr. So a solution to this overheating problem is still appreciated. Note: I have not (re)-loaded the harddisk with stuff yet.


There are some solutions in another Thread: New Raspberry Pi 3 coming. Soon?


Is there an image with Kodi Jarvis? The rest of my systems are on Jarvis, not Krypton and until it’s at a .1 release, I’ll not update.

Also, how does one install noobs? There is a Slice3 noobs tarball, the instructions say to copy the uncompressed tarball to the /os directory. However, there does not appear to be a /os directory.

Other than that, the instructions I found worked.


No there is no Jarvis build for CM3. You’ll just have to wait, although I’ve been impressed with it’s stability…



So here is my check list for moving from the CM1 to CM3.
Please note that I was running already the latest LibreELEC on my CM1 Slice before. So no upgrade of version during the process.
Also, the most cumbersome part was actually having the eMMC recognized on Windows. I tried to copy what seemed to work for me, but I tinkered quite a bit there, so might have miss one step.

Make a back-up of the old config

  • Install the “backup” add-on: http://kodi.wiki/view/Add-on:Backup
  • Configure the add-on and the place where to store the back-up (not on the CM1)
  • Run the add-on and make a back-up
  • Check that the files are copied to their destination
  • Power-off the Slice (with the CM1 in)

Swap the CM1 with the CM3

Flash the eMMC on a Compute Module

  • Dowload and run the installer from https://www.raspberrypi.org/documentation/hardware/computemodule/cm-emmc-flashing.md

  • First connect the slice to your PC through the microUSB port (slice) and double USB (PC)

  • Then power on the Slice

  • Wait for Windows to says that drivers could not be installed

  • Go to Device manager and update drivers for BCM2710

  • Manually load the driver by pointing to C:\Program Files (x86)\Compute Module Boot (with sub-folders)

  • It might recognize it as some Xbox driver. This is OK.

  • Then run rpiboot.exe

  • Some instructions should flash and at the end Windows propose to flash the 4GB

  • Proceed with default options (FAT32…)

  • You should have the 4GB visible in Windows as USB mass storage device

  • Download the installer from LibreELEC from https://libreelec.tv/downloads/

  • Run it

  • Select Slice CM3 and choose to download from remote

  • Then write the image to the correct disk

  • Eject the USB storage through Windows

  • Power-off the Slice and remove microUSB

  • Power-on the Slice again

  • Go through the wizard

  • Install the “backup” add-on again

  • Configure it to point to your back-up folder (not the back-up itself, but its parent folder)

  • Restore the back-up

  • Restart the Slice



I have my slice healy modified (*additional repos etc) how do I copy all this to the CM3?


Use the backup / restore facility


Question !

If I order another Slice from the shop, will it include the new CM3 or are they still shipped with a CM1 ?
Now that my Slice with CM3 module is a lot faster a few of my family members have an intrest in it. :smiley:


Currently Jon and Paul are still supplying with CM1. This is because we don’t have a NOOBS build to support CM3 and it will mean the recovery instructions change!

You could ask them to supply a Slice with CM3 unprogrammed if you’re confident programming it yourself…



Yeah quite confident - I did it - twice :wink:
(without NOOBS though)

OTOH :confused: chewitt supplies a NOOBS build here …
so maybe I’ll have to retry that



Any news regarding CM3 cooling system for the Slice?
Maybe specs or something that we could build ourselves.

Especially something that could be ordered worldwide with no additionnal fee that would be great.



here you have more info Slice CM3 cooling mods