Re flashing of RPI compute module failed!


Have followed all the wiki instruction both using Windows and Linux host computers, but I just can’t get
RPI compute module properly flashed.
In Linux I can mount a volume of about 3.9GB and have reformatted that as a FAT32 volume but there are no other partitions present ( other than the computer hard drive) I have extracted successfully the noobs zip file into this volume but still can’t get it to boot. Get blank screen no activity


That is correct there shouldn’t be any other partitions present…

How did you initially format the volume? Did you use parted or fdisk or something else?

Can you run

sudo parted -l

On the 3G drive you created and run:

ls -l [mountpoint]

mount will show where the drive is mounted (mine shows /dev/sda1 on /media/pi/UNTITLED on my Pi)

You then use the mountpoint to look for the files:

ls -l /media/pi/UNTITLED




I used parted to format and have tried what you’ve suggested and it gas become apparent that I simply can’t locate the storage of the RPI compute module. When I plug in the slice( micro USB only) I see it on my desktop as “USB to IDe SATA device” but when powered it disappears and a 4.1GB drive labelled “untitled” which is what I called it when formatted, but it shows up as /dev/sda2 which is part of the computer 500GB /dev/sda1
I’ll send over a screenshot
Neither through the windows 7 auto flashing technique nor via the Linux commands have I had any success in running rpiboot.
It just doesn’t see any storage partition on the compute module …
I’m pretty sure that at some point I may have deleted or merged a partition because I did have a /dev/sda5 at some point.


You have incorrectly powered up the Slice, to access the eMMC you need to power the Slice from the DC power and have the micro USB plugged into the host system.

If you can see the internal HDD then this means you are not also powering through the DC jack.



Hi Gordon, here’s the screenshot
You have incorrectly powered up the Slice, to access the eMMC you need to power the Slice from the DC power and have the micro USB plugged into the host system.

If you can see the internal HDD then this means you are not also powering through the DC jack.


No, micro USB powered by host computer using two ports AND power plugged in as described.
I removed my internal 2.5" drive so there would be no confusion. With the USB and power plugged I figured all I’d see would be the drive from the computer and any eMMC storage, yet I have never been able to see or mount the eMMC which I am led to believe has two partitions?


I don’t know what’s happening here, it doesn’t make sense you say you’ve removed the hard drive from your Slice, but you’re seeing a 500GB mass storage…

Can you do lsusb at the following points:

  1. before plugging anything into your host computer
  2. After plugging just the uUSB connector
  3. After plugging in the DC jack
  4. After running sudo rpiboot


OK, apologies for the confusion.
The 500GB storage in the previous screenshot is of the host computer running Linux mint.
The drive designated /dev/sda2 for 3.9 GB is also a partition on the host computer.(which I had mistakingly thought was the eMMC storage) Subsequently I put back the 320GB 2.5" HDD back into the Slice before I did the lsusb and here’s what I got back.

What I think it is telling us is that the rpiboot program is either corrupt or not installed properly as I have tried several times to reinstall but the first time I got a fatal error of some sort as I was trying to clone from and then, each time after that, I got user name and password requests to attempt installation only to be met with more and more tasks in Linux for which I’m not equipped ???
I tried the automatic windows 7 installer which again I downloaded all the various programs, such as computemoduleboot only to find that it always hung and was never able to complete the scan or find and mount the so called mass storage drive on the eMMC. This is what led me to remove the internal (320GB) HDD of the Slice because for some reason I was unable to unmount or eject the drive in order to carry out the rest of the reflashing procedure.
So, in summary all this grief came about from what should have been a simple process of updating the OS in the first instance as I was not getting network connectivity???
Instead I’ve been plunged into a crash course on linux and all its foibles and not experienced any joy from my newly received device.


The code can be easily compiled and run if you’re using a debian based linux distribution since you can just follow the instructions.

But otherwise you should follow the instructions for installing the system on windows as per:

Follow the instructions where it says “Windows installer”



OK, so can you confirm that the Windows installer referred to works for Win 10?? because as previously reported, this procedure was followed on a win 7 computer and I was unable to get rpiboot to find the BCM… Module and would just hang.


OK, I’ve abandoned windows and Linux mint and have installed Debian on a RPI and have followed the guidelines for flashing eMMC and I think Im just one step away from completing the re-installation of Slice Noobs but will need your help to get home.

I’ve attached a screenshoot showing the file structures before connecting Slice and after I ran rpiboot and then connected up the Slice(both power and usb).
I can now see the 3.7 GB drive which is sda.
I downloaded and extracted into a folder called noobs on my desktop. (see screen-shot)

I have used DD IF=… many times but what has me stumped is the fact that I’m starting with a zip file not an img file.
Hence, can I please have a precise command or commands for writing AND then ejecting safely the disk on which the image is to be written? (presumably sda)


You can just format the /dev/sda partition and then copy the noobs files onto it (noobs is not supplied as an image)

sudo parted /dev/sda mklabel msdos
sudo parted /dev/sda "mkpart p fat32 4M -1"
sudo mkfs.msdos /dev/sda1
mkdir mp
sudo mount /dev/sda1 mp
sudo cp noobs/* mp
sudo umount mp

Then reboot Slice


Success and jubilation!
just a note however, I did encounter “need to update /etc/fstab” message after very first command which threw me in a spin, so I installed parted on the desktop and was able to copy and paste Noobs content after formatting and partitioning via desktop “Parted” which then automatically mounted the flash drive enabling me to copy over the files.
Cheers and thanks