Updated Slice Builds UNTESTED!


Could you do me a favour, if you ssh in to the Slice and run

vcgencmd version

If you can paste back what you have



Slice (unofficial) Version: devel-20150929103700-r21385-g62dde37
Slice git: 62dde37e19c69c0810e4216b78e9aba32f1cfe67
Slice:~ # vcgencmd version
Sep 23 2015 12:21:14
Copyright © 2012 Broadcom
version c156d00b148c30a3ba28ec376c9c01e95a77d6d5 (clean) (release)
Slice:~ #


Yeah, it seems the issue is resolved in the latest bcm driver, this has not even been pushed to the OE branch yet, it will be best for you to stay on this release until OE push the latest drivers to master, i will let you know once this happens


Latest Build going up now, this has the updated drivers so should be fine for TV

Changes as below


Hi Mike,
Latest build 201510021715 working very well. TV still good, everything else I’ve tested seems to be fine. I think the only problem now, for me, is the random flashing of the LEDs during the start pattern, I note that that only now plays for a few seconds after boot.
Thanks for all your & Gordons hard work.
Regards Kevin.


Yeah i have stopped the repeat of the pattern, when i get 5 mins i want to try and copy the LED pattern from the Slice promo video.

i will have to check for flashes during boot, not something i have seen


Oh, back on 27 Aug, this thread, you said you had the same problem with the LEDs as I and others are having, random flashes during the boot up LED pattern, hopefully you will see it, it doesn’t always do it, probably half the time. TwistedBE has also mentioned it in the “Bloody build updated to Kodi 15.1” thread. Bloody build updated to Kodi 15.1 - OpenELEC 6.0
Regards Kevin.


Oh yeah I remember, but think I only had them when having the long start up led pattern not sure I have seen them with the short pattern, will have to let you know, I have been running the short LEDs for some time now


Another new build will be up soon



New update with Kodi 15.2 rc3




regarding the LED’s i have rebooted my Dev Slice around 40 times today and not had a single strange flash of the LED’s. so either this is fixed it the current version i am running of the issue only happens on a Slice that had a HDD installed, as my Dev Slice has no HDD, i will try and test this evening with my retail Slice


Hi Mike,
I definitely still get it on 20151002171558-r21403-g66a0439.
I’ll down load your latest and give that a try, yes I do have a hard disk fitted, only a 500GB.
Regards, Kevin.


Hi Mike,
I’ve now got 20151005112904-r21436-gc18b03e and it’s doing it quite consistently. Two reboots, did it both times.
As an experiment I also set the FF and FR pattern going (white running line of LEDs) and I’m consistently getting a random green flash in the pattern on the left hand side, that’s in both forward and reverse cases.
Regards, Kevin.


are you just triggering the led pattern from ssh?


while true; do led_png /usr/share/kodi/media/ledpatterns/ffwd.png; sleep .5; done


Hi Mike,
I was doing it by running a film then just pressing the FF or FR button on the remote and leaving it running.
However using your line of code also does it as well, green flash from LED or LEDs on the left hand side of the box, it does it quite frequently, say once or twice every few seconds.
Regards, Kevin.



Any ideas why this could be happening?


Two videos attached.

Regards, Kevin.

New Stable / Nightly / Bloody build [Oct 19 2015]

This is likely to be a problem with the WS2812 bitstream output driver…

Basically what happens is:

You write a bunch of 0RGB values to /dev/ws2812

Each of these is then converted to a bit pattern for writing to the WS2812 devices through the PWM hardware using DMA.

My guess would be that something is going wrong either at the start or at the end of the sequence (the sequence must end with a final line of all zeros to turn off the LEDs otherwise they’ll stay on!)

Does it happen if you increase the sleep time?




On my dev Slice i dont have the issue, but seems Kevin does even running the same build as me

@Bleep, could you test running the command via ssh and see if you get the issue