Upgrading to Compute Module 3 Failed [SOLVED]



As mentionned in the topic, I ordered a Compute Module 3 and simply plugged it in the Slice and tried booting.

The result was just a small red square in the top right corner of my screen for a few secs and then just a black screen / nothing else happens.

I tried reflashing the eMMC by following this procedure :

So I used the provided noobs installer and extracted the zip content inside the RECOVERY Fat 32 partition / safely ejected the USB storage / Unplugged power / Removed usb cable / Replugged the power cable hoping noobs would kick in and reset partitions etc but I m still having the same issue as before (Note : I already followed this procedure successfully previously on compute module 1)

Did anyone else encounter such an issue when upgrading to CM3?

Any lead would be helpfull, thanks


Just a quick update following up on another lead.

I tried to follow this procedure : https://github.com/FiveNinjas/documentation using raspbian image.
I managed to install raspbian and get a proper output but no USB / Ethernet support (I tried to put slice’s dt-blob.bin in the boot partition with no success on next boot)

A working image to flash the eMMC properly would be really helpful.


You need to flash the libreelec image, there is details on their forum, under community builds


Hello Mike,

Thank you found the required link on LibreELEC forums.
I expected to find this information on the Five Ninjas forum to be honest since it’s very specific to the Slice.
Posting it here if anyone else is trying to upgrade to CM3

Topic :

Images (Preview, not considered as stable yet)

In there you will find LibreELEC releases for Slice Compute Module 1 and Compute Module 3.
Make sure you choose the proper file.
CM3 users should download LibreELEC-Slice3.arm-7.95.X files
CM1 users should download LibreELEC-Slice.arm-7.95.X files

Then flash your eMMC normally using the Normal Procedure
We warned that you might screw up your installation if you do it wrong so use it as your own risk.

If anyone has any questions on the matter I ll gladly help.

Gone tweaking Kodi 17 now!